summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-08-03 21:15:43 -0400
committerLeo Famulari <leo@famulari.name>2021-07-27 12:34:57 -0400
commit8e47a8e8a7fe85362b86b724443454222efa639c (patch)
tree6d37134889b242fcd04b2b87e2d117a8a864c1d4
parentd89a5297605e6e6f541396eb756a70dd7d22ba63 (diff)
downloadguix-8e47a8e8a7fe85362b86b724443454222efa639c.tar.gz
gnu: Remove eschalot.
As discussed in <https://bugs.gnu.org/46602>, eschalot does not support
a current release of OpenSSL.

* gnu/packages/crypto.scm (eschalot): Remove variable.
-rw-r--r--gnu/packages/crypto.scm57
1 files changed, 0 insertions, 57 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index c545f47fcf..c511d0a711 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -398,63 +398,6 @@ secure operations. ")
     (license (list license:lgpl2.1+             ; the files keyutils.*
                    license:gpl2+))))            ; the rest
 
-;; There is no release candidate but commits point out a version number,
-;; furthermore no tarball exists.
-(define-public eschalot
-  (let ((commit "0bf31d88a11898c19b1ed25ddd2aff7b35dbac44")
-        (revision "1"))
-    (package
-      (name "eschalot")
-      (version (string-append "1.2.0-" revision "." (string-take commit 7)))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/schnabear/eschalot")
-               (commit commit)))
-         (file-name (string-append name "-" version))
-         (sha256
-          (base32
-           "0lj38ldh8vzi11wp4ghw4k0fkwp0s04zv8k8d473p1snmbh7mx98"))))
-      (inputs
-       `(("openssl" ,openssl-1.0)))     ; for openssl/{bn,pem,rsa,sha}.h
-      (build-system gnu-build-system)
-      (arguments
-       `(#:make-flags (list (string-append "CC=" ,(cc-for-target))
-                            (string-append "PREFIX=" (assoc-ref %outputs "out"))
-                            (string-append "INSTALL=" "install"))
-         ;; XXX: make test would run a !VERY! long hashing of names with the use
-         ;; of a wordlist, the amount of computing time this would waste on build
-         ;; servers is in no relation to the size or importance of this small
-         ;; application, therefore we run our own tests on eschalot and worgen.
-         #:phases
-         (modify-phases %standard-phases
-           (delete 'configure)
-           (replace 'check
-             (lambda _
-               (invoke "./worgen" "8-12" "top1000.txt" "3-10" "top400nouns.txt"
-                       "3-6" "top150adjectives.txt" "3-6")
-               (invoke "./eschalot" "-r" "^guix|^guixsd")
-               (invoke "./eschalot" "-r" "^gnu|^free")
-               (invoke "./eschalot" "-r" "^cyber|^hack")
-               (invoke "./eschalot" "-r" "^troll")))
-           ;; Make install can not create the bin dir, create it.
-           (add-before 'install 'create-bin-dir
-             (lambda* (#:key outputs #:allow-other-keys)
-               (let* ((out (assoc-ref outputs "out"))
-                      (bin (string-append out "/bin")))
-                 (mkdir-p bin)
-                 #t))))))
-      (home-page "https://github.com/schnabear/eschalot")
-      (synopsis "Tor hidden service name generator")
-      (description
-       "Eschalot is a tor hidden service name generator, it allows one to
-produce customized vanity .onion addresses using a brute-force method.  Searches
-for valid names can be run with regular expressions and wordlists.  For the
-generation of wordlists the included tool @code{worgen} can be used.  There is
-no man page, refer to the home page for usage details.")
-      (license (list license:isc license:expat)))))
-
 (define-public ssss
   (package
     (name "ssss")