summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-18 13:41:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:29 +0200
commit903f6db73b0cb4368fc20a81b39b8d9e6c110cbf (patch)
tree7ac1047b9bb8af3ba90486b578096cb4245a45d0
parenta161e8057b9f0d35f2302dbb0d3026877f46d636 (diff)
downloadguix-903f6db73b0cb4368fc20a81b39b8d9e6c110cbf.tar.gz
gnu: texlive-amscls: Remove SIMPLE-TEXLIVE-PACKAGE call.
* gnu/packages/tex.scm (texlive-amscls): Remove SIMPLE-TEXLIVE-PACKAGE
call.
[propagated-inputs]: Add TEXLIVE-AMSFONTS, TEXLIVE-AMSMATH, TEXLIVE-URL.
[description]: Fix typos.
-rw-r--r--gnu/packages/tex.scm45
1 files changed, 23 insertions, 22 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 300f525407..ba50ccd40d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4820,28 +4820,29 @@ commands.  The commands may also be used in plain TeX.")
     (license license:lppl)))
 
 (define-public texlive-amscls
-  (let ((template (simple-texlive-package
-                   "texlive-amscls"
-                   (list "/doc/latex/amscls/"
-                         "/source/latex/amscls/"
-                         "/bibtex/bst/amscls/")
-                   (base32
-                    "0vw0b815slvfqfd8qffyfzb3xfvyv6k77m12xp0l67hs8p08s5b7"))))
-    (package
-      (inherit template)
-      (arguments
-       (substitute-keyword-arguments (package-arguments template)
-         ((#:tex-directory _ #t)
-          "latex/amscls")))
-      (home-page "https://www.ctan.org/pkg/amscls")
-      (synopsis "AMS document classes for LaTeX")
-      (description
-       "This bundle contains three AMS classes: @code{amsartamsart} (for writing
-articles for the AMS), @code{amsbookamsbook} (for books) and
-@code{amsprocamsproc} (for proceedings), together with some supporting
-material.  The material is made available as part of the AMS-LaTeX
-distribution.")
-      (license license:lppl1.3c+))))
+  (package
+    (name "texlive-amscls")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bst/amscls/" "doc/latex/amscls/"
+                   "source/latex/amscls/" "tex/latex/amscls/")
+             (base32
+              "1chy1rqwici66p9brphb3gsprmcyhia9cvm5fn9wb5a9cchxqa08")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-amsfonts
+           texlive-amsmath
+           texlive-url))
+    (home-page "https://www.ctan.org/pkg/amscls")
+    (synopsis "AMS document classes for LaTeX")
+    (description
+     "This bundle contains three AMS classes: @code{amsart} (for writing
+articles for the AMS), @code{amsbook} (for books) and @code{amsproc} (for
+proceedings), together with some supporting material.  The material is made
+available as part of the AMS-LaTeX distribution.")
+    (license license:lppl1.3c+)))
 
 (define-deprecated-package texlive-latex-amscls texlive-amscls)