summary refs log tree commit diff
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-12 02:55:35 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2022-04-12 13:59:17 +0200
commit917c25b3ba0575c6c6e44f8af0d1365bb2378220 (patch)
tree671f057c89a8278646d64c1cf35613297d6ff236
parent1f22508a8a973a20cf33ba1d7f0869ada8258617 (diff)
downloadguix-917c25b3ba0575c6c6e44f8af0d1365bb2378220.tar.gz
gnu: cl-py4cl: Fix path to python3.
* gnu/packages/lisp-xyz.scm (sbcl-py4cl)[arguments]: Add the
  'fix-python3-path' phase.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 16dbad904b..0065f56e7e 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5181,6 +5181,12 @@ port within a range.")
       (arguments
        '(#:phases
          (modify-phases %standard-phases
+           (add-after 'unpack 'fix-python3-path
+             (lambda _
+               (substitute* "src/callpython.lisp"
+                 (("\\*python-command\\* \"python\"")
+                  (string-append "*python-command* "
+                                 "\"" (which "python3") "\"")))))
            (add-after 'unpack 'replace-*base-directory*-var
              (lambda* (#:key outputs #:allow-other-keys)
                ;; In the ASD, the author makes an attempt to