summary refs log tree commit diff
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-06-05 17:05:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-06-05 17:11:14 +0200
commit91e75bb35fd545dc3dc5275428ca4cc17123c76c (patch)
tree83cd0f640f76b0c48b5424819f7486246d75d906
parent940665301de4effd065d24c167f619286f2adf4c (diff)
downloadguix-91e75bb35fd545dc3dc5275428ca4cc17123c76c.tar.gz
gnu: Add python-readpaf.
* gnu/packages/bioinformatics.scm (python-readpaf): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 0b67d8fbe6..251e46061f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1998,6 +1998,25 @@ alignments and perform the following operations:
 ")
     (license license:expat)))
 
+(define-public python-readpaf
+  (package
+    (name "python-readpaf")
+    (version "0.0.10")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "readpaf" version))
+              (sha256
+               (base32
+                "15m6ffks4zwpp1ycwk6n02py6mw2yh7qr0vhpc178b91gldr97ia"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-pandas))
+    (home-page "https://github.com/alexomics/read-paf")
+    (synopsis "Minimap2 PAF file reader")
+    (description
+     "This is a fast parser for minimap2 PAF (Pairwise mApping Format)
+files.")
+    (license license:expat)))
+
 (define-public bioperl-minimal
   (package
     (name "bioperl-minimal")