summary refs log tree commit diff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-02-27 01:23:48 +0100
committerMark H Weaver <mhw@netris.org>2015-02-26 20:53:41 -0500
commit922eaededc0aa4bb051046c906a4321750dbb22a (patch)
tree065bd803149741fcb777fa76452dee90988ccb43
parente1509174957bd9eba777bec86ea290fb44a4bce3 (diff)
downloadguix-922eaededc0aa4bb051046c906a4321750dbb22a.tar.gz
gnu: mu: Update to 0.9.11.
* gnu/packages/mail.scm (mu): Update to 0.9.11.  Update source URI.  Add
  autoconf, automake, and libtool to native-inputs.  Add autoreconf phase.
-rw-r--r--gnu/packages/mail.scm30
1 files changed, 19 insertions, 11 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index dc33c8cbd3..ca25c58f68 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -304,18 +304,22 @@ repository and Maildir/IMAP as LOCAL repository.")
 (define-public mu
   (package
     (name "mu")
-    (version "0.9.9.5")
+    (version "0.9.11")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://mu0.googlecode.com/files/mu-"
+              (uri (string-append "https://github.com/djcb/mu/archive/v"
                                   version ".tar.gz"))
+              (file-name (string-append "mu-" version ".tar.gz"))
               (sha256
                (base32
-                "1hwkliyb8fjrz5sw9fcisssig0jkdxzhccw0ld0l9a10q1l9mqhp"))))
+                "01n1lzq4pfsm5pn932p948d1z55yqc7kkm1ifjxjchb3k8lr66fh"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("glib" ,glib "bin")             ; for gtester
+       ("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
        ("texinfo" ,texinfo)))
     ;; TODO: Add webkit and gtk to build the mug GUI.
     (inputs
@@ -326,14 +330,18 @@ repository and Maildir/IMAP as LOCAL repository.")
        ("gmime" ,gmime)
        ("tzdata" ,tzdata)))             ;for mu/test/test-mu-query.c
     (arguments
-     '(#:phases (alist-cons-before
-                 'check 'check-tz-setup
-                 (lambda* (#:key inputs #:allow-other-keys)
-                   ;; For mu/test/test-mu-query.c
-                   (setenv "TZDIR"
-                           (string-append (assoc-ref inputs "tzdata")
-                                          "/share/zoneinfo")))
-                 %standard-phases)))
+     '(#:phases (alist-cons-after
+                 'unpack 'autoreconf
+                 (lambda _
+                   (zero? (system* "autoreconf" "-vi")))
+                 (alist-cons-before
+                   'check 'check-tz-setup
+                   (lambda* (#:key inputs #:allow-other-keys)
+                     ;; For mu/test/test-mu-query.c
+                     (setenv "TZDIR"
+                             (string-append (assoc-ref inputs "tzdata")
+                                            "/share/zoneinfo")))
+                   %standard-phases))))
     (home-page "http://www.djcbsoftware.nl/code/mu/")
     (synopsis "Quickly find emails")
     (description