summary refs log tree commit diff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2021-11-09 15:02:30 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 21:58:37 -0500
commit9273d83bc3b1b3c1925c01f8fddde794d7b55025 (patch)
treec1be3e36797f2ee97a6d6a347745ef432fb500a6
parent79ca578182b6a35bd567d408a32e5728e4f2a552 (diff)
downloadguix-9273d83bc3b1b3c1925c01f8fddde794d7b55025.tar.gz
gnu: orbit2: Fix parallel build.
* gnu/packages/gnome.scm (orbit2): Remove trailing #t.
[phases]: Add a phase so that orbit-name-server-2 depends on
libname-server-2.a.

Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 80266b118c..2321b5aa81 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3636,11 +3636,19 @@ functionality was designed to be as reusable and portable as possible.")
        ;; ... which they then completly ignore !!
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-parallel-build
+           ;; Parallel build fails because of a failed dependency,
+           ;; https://bugzilla.gnome.org/show_bug.cgi?id=732274
+           (lambda _
+             (substitute* "src/services/name/Makefile.am"
+               (("orbit_name_server_2_DEPENDENCIES = \\$(DEPS) CosNaming.h")
+                "orbit_name_server_2_DEPENDENCIES = \
+$(DEPS) CosNaming.h libname-server-2.a"))))
          (add-before 'configure 'ignore-deprecations
            (lambda _
              (substitute* "linc2/src/Makefile.in"
-               (("-DG_DISABLE_DEPRECATED") "-DGLIB_DISABLE_DEPRECATION_WARNINGS"))
-             #t)))))
+               (("-DG_DISABLE_DEPRECATED")
+                "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
     (inputs `(("glib" ,glib)
               ("libidl" ,libidl)))
     (native-inputs