summary refs log tree commit diff
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-02-20 15:15:12 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-02-23 21:56:41 +0100
commit927b6728f0129d625892e69f1fff6dd7e3324c66 (patch)
treecc6d1aba239f79108137df178930703e89543e16
parent89b5c60ef9f75cb747608f4ead8f3a2fe1cb1136 (diff)
downloadguix-927b6728f0129d625892e69f1fff6dd7e3324c66.tar.gz
gnu: Add wxwidgets.
* gnu/packages/wxwidgets.scm: New file.
* gnu-system.am (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/wxwidgets.scm97
2 files changed, 98 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 24c5dc1a91..3eb7893481 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -294,6 +294,7 @@ GNU_SYSTEM_MODULES =				\
   gnu/packages/wine.scm				\
   gnu/packages/wordnet.scm			\
   gnu/packages/wv.scm				\
+  gnu/packages/wxwidgets.scm			\
   gnu/packages/xfig.scm				\
   gnu/packages/xiph.scm				\
   gnu/packages/xml.scm				\
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
new file mode 100644
index 0000000000..5406aedc6e
--- /dev/null
+++ b/gnu/packages/wxwidgets.scm
@@ -0,0 +1,97 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages wxwidgets)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module ((guix licenses) #:prefix l:)
+  #:use-module (guix build-system glib-or-gtk)
+  #:use-module (guix build utils)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages compression)
+  #:use-module (gnu packages databases)
+  #:use-module (gnu packages gl)
+  #:use-module (gnu packages gstreamer)
+  #:use-module (gnu packages gtk)
+  #:use-module (gnu packages image)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages sdl)
+  #:use-module (gnu packages xorg))
+
+(define-public wxwidgets
+  (package
+    (name "wxwidgets")
+    (version "3.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/wxwindows/" version
+                           "/wxWidgets-" version ".tar.bz2"))
+       (sha256
+        (base32 "0paq27brw4lv8kspxh9iklpa415mxi8zc117vbbbhfjgapf7js1l"))))
+    (build-system glib-or-gtk-build-system)
+    ;; TODO: add WebKit
+    (inputs
+     `(("glu" ,glu)
+       ;; XXX gstreamer-0.10 builds fail
+       ;; ("gstreamer" ,gstreamer-0.10)
+       ("gtk" ,gtk+)
+       ("libjpeg" ,libjpeg)
+       ("libmspack" ,libmspack)
+       ("libsm" ,libsm)
+       ("libtiff" ,libtiff)
+       ("mesa" ,mesa)
+       ("sdl" ,sdl)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (arguments
+     '(#:configure-flags
+       '("--with-regex=sys" "--with-libmspack" "--with-sdl")
+       ;; No 'check' target.
+       #:tests? #f))
+    (home-page "https://www.wxwidgets.org/")
+    (synopsis "Widget toolkit for creating graphical user interfaces")
+    (description
+     "wxWidgets is a C++ library that lets developers create applications with
+a graphical user interface.  It has language bindings for Python, Perl, Ruby
+and many other languages.")
+    (license (list l:lgpl2.0+ (l:fsf-free "file://doc/license.txt")))))
+
+(define-public wxwidgets-2
+  (package
+    (inherit wxwidgets)
+    (version "2.8.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://sourceforge.net/projects/wxwindows/files/"
+                           version "/wxGTK-" version ".tar.gz"))
+       (sha256
+        (base32 "1gjs9vfga60mk4j4ngiwsk9h6c7j22pw26m3asxr1jwvqbr8kkqk"))))
+    (inputs
+     `(("gtk" ,gtk+-2)
+       ("libjpeg" ,libjpeg)
+       ("libtiff" ,libtiff)
+       ("libmspack" ,libmspack)
+       ("sdl" ,sdl)
+       ("unixodbc" ,unixodbc)))
+    (arguments
+     `(#:configure-flags
+       '("--enable-unicode" "--with-regex=sys" "--with-sdl")
+       ;; No 'check' target.
+       #:tests? #f))))