summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 23:49:43 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-15 00:09:08 -0400
commit929551f634af9752b346043efa4d718796d1efc3 (patch)
tree27fcf084c2e700f0bf5f1c24731603741b5ca060
parent7943de8ece48bd65dc33f6df76940c74c171febe (diff)
downloadguix-929551f634af9752b346043efa4d718796d1efc3.tar.gz
gnu: python-jsonschema: Update to 4.5.1.
* gnu/packages/python-xyz.scm (python-jsonschema): Update to 4.5.1.
[arguments]: Remove extraneous inputs, outputs bindings from check phase
override.  Add pretend-version phase.
[propagated-inputs]: Add python-importlib-metadata and
python-typing-extensions.  Remove python-six.
* gnu/packages/astronomy.scm (python-asdf): Replace python-jsonschema-next
with python-jsonschema.
(python-asdf-standard, python-gwcs): Likewise.
* gnu/packages/matrix.scm (python-matrix-nio): Likewise.
* gnu/packages/python-xyz.scm (python-robotframework): Likewise.
-rw-r--r--gnu/packages/astronomy.scm6
-rw-r--r--gnu/packages/matrix.scm2
-rw-r--r--gnu/packages/python-xyz.scm58
3 files changed, 27 insertions, 39 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 1800bb141c..39a5811e8a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2680,7 +2680,7 @@ datetime object.")
            python-importlib-metadata
            python-importlib-resources
            python-jmespath
-           python-jsonschema-next
+           python-jsonschema
            python-lz4
            python-numpy
            python-pyyaml))
@@ -2715,7 +2715,7 @@ implementation of the ASDF Standard.")
                                       (list "tests/test_manifests.py"
                                             "tests/test_integration.py")))))))
     (native-inputs (list python-astropy
-                         python-jsonschema-next
+                         python-jsonschema
                          python-pypa-build
                          python-pytest
                          python-packaging
@@ -2962,7 +2962,7 @@ install an implementation package such as gwcs.")
         (base32 "0v9qcq6zl74d6s882s6xmas144jfalvll6va8rvrxmvpx4vqjzhg"))))
     (build-system pyproject-build-system)
     (native-inputs
-     (list python-jsonschema-next
+     (list python-jsonschema
            python-jmespath
            python-pytest
            python-pytest-doctestplus
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 7086482ef8..f356674ed9 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -218,7 +218,7 @@ homeserver and generally help bootstrap the ecosystem.")
            python-future
            python-h11
            python-h2
-           python-jsonschema-next
+           python-jsonschema
            python-logbook
            python-olm
            python-peewee
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 99f3c62353..5d7b2f912c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4080,37 +4080,6 @@ compare, diff, and patch JSON and JSON-like structures in Python.")
 (define-public python-jsonschema
   (package
     (name "python-jsonschema")
-    (version "3.2.0")
-    (source (origin
-             (method url-fetch)
-             (uri (pypi-uri "jsonschema" version))
-             (sha256
-              (base32
-               "0ykr61yiiizgvm3bzipa3l73rvj49wmrybbfwhvpgk3pscl5pa68"))))
-    (build-system python-build-system)
-    (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
-             (when tests?
-               (setenv "JSON_SCHEMA_TEST_SUITE" "json")
-               (invoke "trial" "jsonschema")))))))
-    (native-inputs
-     `(("python-setuptools_scm" ,python-setuptools-scm)
-       ("python-twisted" ,python-twisted)))
-    (propagated-inputs
-     (list python-attrs python-pyrsistent python-six))
-    (home-page "https://github.com/Julian/jsonschema")
-    (synopsis "Implementation of JSON Schema for Python")
-    (description
-     "Jsonschema is an implementation of JSON Schema for Python.")
-    (license license:expat)))
-
-;;; TODO: Make the default python-jsonschema on core-updates
-(define-public python-jsonschema-next
-  (package
-    (inherit python-jsonschema)
     ;; XXX: Update to the latest version requires new build system - Hatch
     ;; https://hatch.pypa.io/
     (version "4.5.1")
@@ -4121,13 +4090,32 @@ compare, diff, and patch JSON and JSON-like structures in Python.")
        (sha256
         (base32 "1z0x22691jva7lwfcfh377jdmlz68zhiawxzl53k631l34k8hvbw"))))
     (build-system pyproject-build-system)
-    (native-inputs
-     (list python-setuptools-scm python-twisted))
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'build 'pretend-version
+            ;; The version string is usually derived via setuptools-scm, but
+            ;; without the git metadata available, the version string is set to
+            ;; '0.0.0'.
+            (lambda _
+              (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)))
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (setenv "JSON_SCHEMA_TEST_SUITE" "json")
+                (invoke "trial" "jsonschema")))))))
+    (native-inputs (list python-setuptools-scm python-twisted))
     (propagated-inputs
      (list python-attrs
            python-importlib-metadata
            python-pyrsistent
-           python-typing-extensions))))
+           python-typing-extensions))
+    (home-page "https://github.com/Julian/jsonschema")
+    (synopsis "Implementation of JSON Schema for Python")
+    (description
+     "Jsonschema is an implementation of JSON Schema for Python.")
+    (license license:expat)))
 
 (define-public python-schema
   (package
@@ -5496,7 +5484,7 @@ operating_system/path_expansion.robot")))
                 (invoke "xvfb-run" "atest/run.py")))))))
     (native-inputs
      (list python-docutils
-           python-jsonschema-next
+           python-jsonschema
            python-invoke
            python-lxml
            python-pygments