summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 14:01:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 14:46:24 +0200
commit93193357756979961ac0e6f3242c0a46b36629f9 (patch)
tree09e26794d7f657b8baf4337dcbc8d86fc441e8a3
parenta9b7df3607ba5b135a87a5e57d03910b953e449e (diff)
downloadguix-93193357756979961ac0e6f3242c0a46b36629f9.tar.gz
gnu: Add texlive-lollipop.
* gnu/packages/tex.scm (texlive-lollipop): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 154b029e95..d0f5b64b87 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5971,6 +5971,29 @@ proofs and boxes.  It creates proofs in a style similar to that used in
 @emph{Logic in Computer Science} by Huth and Ryan.")
     (license license:lppl1.3+)))
 
+(define-public texlive-lollipop
+  (package
+    (name "texlive-lollipop")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/otherformats/lollipop/" "tex/lollipop/")
+             (base32
+              "0xdldlnhsr2n8544j9vd6gllin8bfkpcbhlpmxlhrvjl5bdg0rjp")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:create-formats #~(list "lollipop")))
+    (propagated-inputs (list texlive-cm texlive-hyphen-base))
+    (home-page "https://ctan.org/pkg/lollipop")
+    (synopsis "TeX made easy")
+    (description
+     "Lollipop is a macro package that functions as a toolbox for writing TeX
+macros.  Its main aim is to make macro writing so easy that implementing
+a fully new layout in TeX would become a matter of less than an hour for an
+average document.  The aim is that such a task could be accomplished by
+someone with only a very basic training in TeX programming.")
+    (license license:gpl3)))
+
 (define-public texlive-longdivision
   (package
     (name "texlive-longdivision")