summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-06-18 16:17:04 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-06-20 07:06:58 +0200
commit93dba17c63ab879261bc01b865e8c2c5d5c91d29 (patch)
treee03b8b61613bf878f699170838b524054ccf40cf
parent5edc24ec2cae6c5352ad358971006b1320bf52bf (diff)
downloadguix-93dba17c63ab879261bc01b865e8c2c5d5c91d29.tar.gz
gnu: Add emacs-ace-window.
* gnu/packages/emacs.scm (emacs-ace-window): New variable.
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 44c4e4e018..db00502738 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1800,6 +1800,31 @@ such as the positions of characters, words, line beginnings, links, or
 windows.")
     (license license:gpl3+)))
 
+(define-public emacs-ace-window
+  (package
+    (name "emacs-ace-window")
+    (version "0.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/abo-abo/ace-window/archive/"
+                           version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1p2sgfl5dml4zbd6ldql6lm2m9vmd236ah996ni32x254s48j5pn"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-avy" ,emacs-avy)))
+    (home-page "https://github.com/abo-abo/ace-window")
+    (synopsis "Quickly switch windows in Emacs")
+    (description
+     "@code{ace-window} is meant to replace @code{other-window}.
+In fact, when there are only two windows present, @code{other-window} is
+called.  If there are more, each window will have its first character
+highlighted.  Pressing that character will switch to that window.")
+    (license license:gpl3+)))
+
 (define-public emacs-clojure-mode
   (package
     (name "emacs-clojure-mode")