summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-10 23:23:57 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-13 11:50:52 +0100
commit94ba338ee95f54a72cd49e533e3a5ee75939a6cd (patch)
treed604322eeb41a2ac00c2d7a0321e35e5184c1b72
parent548fbc5e36de3461f28411e5a4faf42a95a9440d (diff)
downloadguix-94ba338ee95f54a72cd49e533e3a5ee75939a6cd.tar.gz
gnu: rust-futures-sink-0.3: Update to 0.3.12.
* gnu/packages/crates-io.scm (rust-futures-sink-0.3): Update to 0.3.12.
[arguments]: Skip build.
[home-page]: Update URI.
[synopsis, description]: Improve typography.
-rw-r--r--gnu/packages/crates-io.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b6a90f0c51..978b77c773 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -15026,7 +15026,7 @@ different @code{Future}s at once and handling the first one to complete.")
 (define-public rust-futures-sink-0.3
   (package
     (name "rust-futures-sink")
-    (version "0.3.8")
+    (version "0.3.12")
     (source
      (origin
        (method url-fetch)
@@ -15035,12 +15035,13 @@ different @code{Future}s at once and handling the first one to complete.")
         (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "0gfb1z97q861ki6lqsvpgfn3hnm9w3vkrf82dc00xrff95d1jy7q"))))
+         "1mj22d4w6digh7wfp6jkr5fdcl9r138q41fxzm1yg8mx568cdxfa"))))
     (build-system cargo-build-system)
-    (home-page "https://rust-lang-nursery.github.io/futures-rs")
-    (synopsis "Asynchronous `Sink` trait for the futures-rs library")
+    (arguments `(#:skip-build? #t))
+    (home-page "https://rust-lang.github.io/futures-rs")
+    (synopsis "Asynchronous @code{Sink} trait for the @code{futures-rs} library")
     (description "This package provides the asynchronous @code{Sink} trait for
-the futures-rs library.")
+the @code{futures-rs} library.")
     (license (list license:expat license:asl2.0))))
 
 (define-public rust-futures-sink-preview-0.3