summary refs log tree commit diff
diff options
context:
space:
mode:
authorSkylar Chan <schan12@umd.edu>2023-10-31 20:39:51 -0400
committerLudovic Courtès <ludo@gnu.org>2023-11-15 18:29:38 +0100
commit9524d8cd0bc752b8b8387b0e669f780e0bd20ed1 (patch)
treecbd8a4c3746b63ee970eb04b12381ba3eaf8ee4e
parent3493832260fdb7298c2f661e1c9fbe366e578693 (diff)
downloadguix-9524d8cd0bc752b8b8387b0e669f780e0bd20ed1.tar.gz
gnu: whoogle-search: Update to 0.8.3.
* gnu/packages/python-web.scm (whoogle-search): Update to 0.8.3.
[propagated-inputs]: Remove python-attrs, python-cachelib, python-certifi, python-cffi,
python-chardet, python-click, python-flask-session, python-idna,
python-itsdangerous, python-jinja2, python-markupsafe,
python-more-itertools, python-packaging, python-pluggy, python-py,
python-pycodestyle, python-pycparser, python-pyopenssl,
python-pyparsing, python-pysocks, python-dateutil, python-soupsieve,
python-urllib3, python-wcwidth, and python-werkzeug.

Change-Id: Ie665b548cdd996fa74e70313b02b9b5c2a0d75d2
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-web.scm35
1 files changed, 5 insertions, 30 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8d5af5bd46..9d8f3c156f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5204,54 +5204,29 @@ with oauthlib.")
 (define-public whoogle-search
   (package
     (name "whoogle-search")
-    (version "0.8.2")
+    (version "0.8.3")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "whoogle-search" version))
               (sha256
                (base32
-                "1r6ymainwc3b8aar90b74mpnx3rsfscgzh0llwvsb03fbhiypw5g"))))
+                "09b9k97jflajvrs0npyz994rj8xkk400s98jw63b6vpsgw9q9nk4"))))
     (build-system pyproject-build-system)
     (arguments
      (list
       ;; The tests need network access
       #:tests? #f))
     (propagated-inputs
-     (list python-attrs
-           python-beautifulsoup4
-           python-cachelib
-           python-certifi
-           python-cffi
+     (list python-beautifulsoup4
            python-brotli
-           python-chardet
-           python-click
            python-cryptography
            python-cssutils
            python-defusedxml
            python-flask
-           python-flask-session
-           python-idna
-           python-itsdangerous
-           python-jinja2
-           python-markupsafe
-           python-more-itertools
-           python-packaging
-           python-pluggy
-           python-py
-           python-pycodestyle
-           python-pycparser
-           python-pyopenssl
-           python-pyparsing
-           python-pysocks
-           python-dateutil
+           python-dotenv
            python-requests
-           python-soupsieve
            python-stem
-           python-urllib3
-           python-waitress
-           python-wcwidth
-           python-werkzeug
-           python-dotenv))
+           python-waitress))
     (home-page "https://github.com/benbusby/whoogle-search")
     (synopsis "Self-hosted, ad-free, privacy-respecting metasearch engine")
     (description