summary refs log tree commit diff
diff options
context:
space:
mode:
authorYovan Naumovski <yovan@gorski.stream>2023-03-31 19:25:30 +0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-03 13:09:59 +0200
commit956a58821d776577606296f026d77dd2441b9f10 (patch)
tree602561b878f7dbf269a75b4ea0dbca1b5c8e85dc
parent996f2a1609b8d9e17bcc2e0a9bea6a87fb4662c7 (diff)
downloadguix-956a58821d776577606296f026d77dd2441b9f10.tar.gz
gnu: Add dool.
* gnu/packages/admin.scm (dool): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/admin.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index f48362c203..62a5443d66 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3448,6 +3448,52 @@ throughput (in the same interval).")
     (home-page "http://dag.wiee.rs/home-made/dstat/")
     (license license:gpl2+)))
 
+(define-public dool
+  (package
+    (name "dool")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/scottchiefbaker/dool")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name "dool" version))
+       (sha256
+        (base32 "13qq52lq7z3pl2mgrhwqh8c69p9x5rkyjqjswszd6vdbzm7zk7yq"))))
+    (build-system python-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'remove-symlinks-and-snap-packaging
+            ;; Remove symlinks that make 'ensure-no-mtimes-pre-1980 fail.
+            (lambda _
+              (delete-file "examples/dstat.py")
+              (delete-file-recursively "packaging/snap")))
+          (delete 'build)
+          (replace 'install
+            (lambda _
+              (substitute* "install.py"
+                (("(bin_dir *= ?).*" _ prefix)
+                 (string-append prefix  "\"" #$output "/bin/\"\n"))
+                (("(plugin_dir *= ?).*" _ prefix)
+                 (string-append prefix "\"" #$output "/share/dool/\"\n"))
+                (("(manpage_dir *= ?).*" _ prefix)
+                 (string-append prefix "\"" #$output "/share/man/man1/\"\n")))
+              (invoke "python" "install.py" "--root")))
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (invoke "./dool" "--version")
+                (invoke "./dool" "-taf" "1" "5")))))))
+    (synopsis "Command line system resource monitoring tool")
+    (description "Dool is a command line tool to monitor many aspects of your
+system: CPU, Memory, Network, Load Average, etc.  It also includes a robust
+plug-in architecture to allow monitoring other system metrics.")
+    (home-page "https://github.com/scottchiefbaker/dool")
+    (license license:gpl2+)))
+
 (define-public thefuck
   (package
     (name "thefuck")