summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2021-07-17 17:48:26 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2021-07-17 17:48:26 +0200
commit9591f6855090978a1eedb39bbaab48cfc0d858a8 (patch)
tree52c8260f06df8ac515179c1bf2f8bf8f7be98631
parent9cb35c02164d929fcb8929e7f454df215df8cf25 (diff)
downloadguix-9591f6855090978a1eedb39bbaab48cfc0d858a8.tar.gz
gnu: arx-libertatis: Update to 1.2.
* gnu/packages/games.scm (arx-libertatis): Update to 1.2.
[inputs]: Replace sdl with sdl2 and mesa with libepoxy.
-rw-r--r--gnu/packages/games.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9a44c4d701..8c6b5523f1 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8771,7 +8771,7 @@ game field is extended to 4D space, which has to filled up by the gamer with
 (define-public arx-libertatis
   (package
     (name "arx-libertatis")
-    (version "1.1.2")
+    (version "1.2")
     (source
      (origin
        (method url-fetch)
@@ -8779,7 +8779,7 @@ game field is extended to 4D space, which has to filled up by the gamer with
                            version ".tar.xz"))
        (sha256
         (base32
-         "0hjfxlsmp8wwqr06snv2dlly2s79ra0d9aw49gkp6rn8m50b9bc2"))))
+         "035dflxffa98bxmxkrqfizmhvnr09wyhhmzaqxk92772qil7gkxs"))))
     (build-system cmake-build-system)
     (outputs '("out" "installer"))
     (arguments
@@ -8824,8 +8824,8 @@ game field is extended to 4D space, which has to filled up by the gamer with
                (rename-file (string-append out "/bin/arx-install-data")
                             (string-append installer "/bin/arx-install-data"))))))))
     (inputs
-     `(("sdl" ,sdl)                     ; Switch to sdl2 in >1.1.2.
-       ("mesa" ,mesa)                   ; Switch to libepoxy in >1.1.2.
+     `(("sdl2" ,sdl2)
+       ("libepoxy" ,libepoxy)
        ("glew" ,glew)
        ("openal" ,openal)
        ("zlib" ,zlib)