summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:03:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:06 +0200
commit95f4a72980ac873806b2dd473d1a7bb0dd4222bd (patch)
tree20fb58fe07877b7d5b773e4246afa3abd9ebcc6b
parentbf1754eca0793a2dc40fa6ea177afbea08c1ff2e (diff)
downloadguix-95f4a72980ac873806b2dd473d1a7bb0dd4222bd.tar.gz
gnu: Add texlive-twoup.
* gnu/packages/tex.scm (texlive-twoup): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 400c482f55..e5e6f74dad 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -98669,6 +98669,28 @@ Page numbers appear on the included pages, and not on the landscape container
 page.")
     (license license:public-domain)))
 
+(define-public texlive-twoup
+  (package
+    (name "texlive-twoup")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/twoup/" "source/latex/twoup/"
+                   "tex/latex/twoup/")
+             (base32
+              "0s33w3mvpkw2jy2vxfbbagasxc37vi09dlkn9kbi0917mz8k5i70")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/twoupltx")
+    (synopsis "Print two virtual pages on each physical page")
+    (description
+     "Some tools massage PostScript into booklet and two-up printing --- that is,
+printing two logical pages side by side on one side of one sheet of paper.
+However, some LaTeX preliminaries are necessary to use those tools.  The
+@code{twoup} package provides such preliminaries and gives advice on how to
+use the PostScript tools.")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar