summary refs log tree commit diff
diff options
context:
space:
mode:
authorOlivier Dion <olivier.dion@polymtl.ca>2022-08-12 19:24:12 -0400
committerMathieu Othacehe <othacehe@gnu.org>2022-08-15 10:22:38 +0200
commit9641e64b434fee1d2538cbf8224b84bd4a186750 (patch)
treee1a221d18d3219f161685f2b6870cc6ffd14d6c9
parent07f807f12c0949e9deeee09b4a28bb1f810b26ca (diff)
downloadguix-9641e64b434fee1d2538cbf8224b84bd4a186750.tar.gz
gnu: Add lttng-modules.
* gnu/packages/instrumentation.scm (lttng-modules): New variable.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/instrumentation.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index f52cf11505..2c0b435075 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2021 Olivier Dion <olivier.dion@polymtl.ca>
+;;; Copyright © 2021, 2022 Olivier Dion <olivier.dion@polymtl.ca>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -50,6 +50,7 @@
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system linux-module)
   #:use-module (guix download)
   #:use-module (guix gexp)
   #:use-module (guix git-download)
@@ -206,6 +207,30 @@ interactive SVGs out of traces genated from various tracing tools.  It comes
 with the script @command{flamegraph.pl} and many stackcollapse scripts.")
       (license license:cddl1.0))))
 
+(define-public lttng-modules
+  (package
+    (name "lttng-modules")
+    (version "2.13.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://lttng.org/files/lttng-modules/"
+                                  "lttng-modules-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1vm9nnjvid7acsvgwnjyxd60ih9rmbhnfjldxip58n8x9q7d0nb1"))))
+    (build-system linux-module-build-system)
+    (arguments
+     `(#:tests? #f ; no tests
+       #:make-flags (list "CONFIG_LTTNG=m"
+                          "CONFIG_LTTNG_CLOCK_PLUGIN_TEST=m")))
+    (home-page "https://lttng.org/")
+    (synopsis "LTTng kernel modules for the LTTng tracer toolset")
+    (description
+     "LTTng kernel modules are Linux kernel modules which make
+LTTng kernel tracing possible.  They include essential control modules and
+many probes which instrument numerous interesting parts of Linux.")
+    (license (list license:lgpl2.1 license:gpl2 license:expat))))
+
 (define-public lttng-ust
   (package
     (name "lttng-ust")