summary refs log tree commit diff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-11-05 01:58:33 +0000
committerLudovic Courtès <ludo@gnu.org>2021-12-12 00:27:55 +0100
commit9660c2f158f296dc162fd08d08c770095a102b2a (patch)
tree35de647af488b33c7421cad24c97a54e4ad00099
parent32135392dd6de8eebcbcf616d9d326ddaa359ab0 (diff)
downloadguix-9660c2f158f296dc162fd08d08c770095a102b2a.tar.gz
gnu: python-s3transfer: Honor #:tests? flag.
* gnu/packages/python-web.scm (python-s3transfer)[arguments]: Adjust custom
'check phase to honor the #:tests? flag.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-web.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8ad43b8aa4..9e7d4113ab 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3426,10 +3426,11 @@ Betamax that may possibly end up in the main package.")
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             ;; Some of the 'integration' tests require network access or
-             ;; login credentials.
-             (invoke "nosetests" "--exclude=integration"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               ;; Some of the 'integration' tests require network access or
+               ;; login credentials.
+               (invoke "nosetests" "--exclude=integration")))))))
     (native-inputs
      `(("python-docutils" ,python-docutils)
        ("python-mock" ,python-mock)