summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-12-28 08:37:20 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-12-28 08:41:54 +0100
commit96f5e2e9e4f774e2d964f76b53e6455e4e59fb8d (patch)
tree65af351d6a7aebbefc9d96d22907e706f52bdc82
parent93e5c93e4c3ba60bfe277658b9656e2d9eb2d486 (diff)
downloadguix-96f5e2e9e4f774e2d964f76b53e6455e4e59fb8d.tar.gz
gnu: Add python-ledgerblue.
* gnu/packages/finance.scm: Import (gnu packages libusb).
(python-ledgerblue, python2-ledgerblue): New variables.
-rw-r--r--gnu/packages/finance.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index cb0cfda25e..0322ef7ead 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -41,6 +41,7 @@
   #:use-module (gnu packages libedit)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages libunwind)
+  #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages pkg-config)
@@ -556,3 +557,32 @@ of Bitcoin BIP-0039.")
 
 (define-public python2-mnemonic
   (package-with-python2 python-mnemonic))
+
+(define-public python-ledgerblue
+  (package
+    (name "python-ledgerblue")
+    (version "0.1.16")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "ledgerblue" version))
+        (sha256
+          (base32
+            "010mghaqh1cmz3a0ifc3f40mmyplilwlw7kpha2mzyrrff46p9gb"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-ecpy" ,python-ecpy)
+       ("python-future" ,python-future)
+       ("python-hidapi" ,python-hidapi)
+       ("python-pillow" ,python-pillow)
+       ("python-protobuf" ,python-protobuf)
+       ("python-pycrypto" ,python-pycrypto)))
+    (home-page "https://github.com/LedgerHQ/blue-loader-python")
+    (synopsis "Python library to communicate with Ledger Blue/Nano S")
+    (description "@code{ledgerblue} is a Python library to communicate with
+Ledger Blue/Nano S.")
+    (license license:asl2.0)))
+
+(define-public python2-ledgerblue
+  (package-with-python2 python-ledgerblue))
+