summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-05-15 17:49:18 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-17 15:16:46 +0200
commit97a92ab2adbeb58fc4d90fec7eeabb872bf6777a (patch)
tree139a37084acb1e1c32329b4f89e3719ba64f90e8
parent889df771664032538f058a8d70fb8906c123dbfd (diff)
downloadguix-97a92ab2adbeb58fc4d90fec7eeabb872bf6777a.tar.gz
gnu: tor: Update to 0.4.3.5.
* gnu/packages/tor.scm (tor): Update to 0.4.3.5.
[arguments]: Enable compression features that aren't auto-detected.
[native-inputs]: Use the default Python (3).
[inputs]: Order alphabetically.
-rw-r--r--gnu/packages/tor.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 4ec503d2ed..2f2623b0e6 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -51,24 +51,28 @@
 (define-public tor
   (package
     (name "tor")
-    (version "0.4.2.7")
+    (version "0.4.3.5")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://dist.torproject.org/tor-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "0v82ngwwmmcb7i9563bgsmrjy6xp83xyhqhaljygd0pkvlsxi886"))))
+               "0s6qspi102drn1nk3gfxs51x992xarc44gkfsi8y3l48wr50wsk1"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags
+       (list "--enable-lzma"
+             "--enable-zstd")))
     (native-inputs
      `(("pkg-config" ,pkg-config)
-       ("python" ,python-2)))           ; for tests
+       ("python" ,python)))             ; for tests
     (inputs
-     `(("zlib" ,zlib)
-       ("openssl" ,openssl)
-       ("libevent" ,libevent)
+     `(("libevent" ,libevent)
        ("libseccomp" ,libseccomp)
+       ("openssl" ,openssl)
        ("xz" ,xz)
+       ("zlib" ,zlib)
        ("zstd" ,zstd "lib")))
     (home-page "https://www.torproject.org/")
     (synopsis "Anonymous network router to improve privacy on the Internet")