summary refs log tree commit diff
diff options
context:
space:
mode:
authorArnaud DABY-SEESARAM <ds-ac@nanein.fr>2024-01-10 08:43:26 +0100
committerJulien Lepiller <julien@lepiller.eu>2024-02-08 23:21:30 +0100
commit97d574ddc4962117915c0af46323ca365fbc0afc (patch)
treedbc43217b7cdddbe1827eb38100486694efa36cc
parent93f4f69a6931f56cdc36619925ff5a21c5c2d846 (diff)
downloadguix-97d574ddc4962117915c0af46323ca365fbc0afc.tar.gz
gnu: Add ocaml-ppx-import.
* gnu/packages/ocaml.scm (ocaml-ppx-import): New variable.

Change-Id: Ie9619653f2b3ecc4458394709e37c4a433f875dd
Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8b443f38a3..dda142a092 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2670,6 +2670,31 @@ layer.")
 yaml for OCaml types.")
     (license license:isc)))
 
+(define-public ocaml-ppx-import
+  (package
+    (name "ocaml-ppx-import")
+    (version "1.10.0")
+    (home-page "https://github.com/ocaml-ppx/ppx_import")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              (url home-page)
+              (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "06srfd6whfwkmjvl6m61kvc65fb7j9b25bhfr1mp338zm87smv5p"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-ppx-deriving ocaml-ppxlib
+                             ocaml-ppx-sexp-conv))
+    (native-inputs (list ocaml-ounit ocaml-sexplib0))
+    (properties `((upstream-name . "ppx_import")))
+    (synopsis "Extension for importing declarations from interface files.")
+    (description
+     "Ppx-import is a syntax extension for importing declarations from
+interface files.")
+    (license license:expat)))
+
 (define-public ocaml-parmap
   (package
     (name "ocaml-parmap")