summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:53:30 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:39 +0200
commit991b989c1b542f2cbb80fba7fa9cd20ec439b53f (patch)
treea8a1868ff656277bb8e875f03498f274f2fb1259
parent6e2e690d65ca47ecfb61fb52f70f4c3daf0b9902 (diff)
downloadguix-991b989c1b542f2cbb80fba7fa9cd20ec439b53f.tar.gz
gnu: Add texlive-punk-latex.
* gnu/packages/tex.scm (texlive-punk-latex): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e729df3cf6..8c799761b7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -21872,6 +21872,26 @@ Metafont source.  The package also offers LaTeX support for them, although
 @code{punk-latex} is a better choice.")
     (license license:knuth)))
 
+(define-public texlive-punk-latex
+  (package
+    (name "texlive-punk-latex")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/punk-latex/"
+                   "tex/latex/punk-latex/")
+             (base32
+              "1gkbv3fwlfq8f3nn9zibhzwa5xw2scaf3xnkvlbxqcslmi129b2l")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/punk-latex")
+    (synopsis "LaTeX support for Punk fonts")
+    (description
+     "The package and @file{.fd} file provide support for Knuth's Punk fonts.
+Although that bundle also offers support within LaTeX; the present package is
+to be preferred.")
+    (license license:gpl3+)))
+
 (define-public texlive-pythonhighlight
   (package
     (name "texlive-pythonhighlight")