summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-05 08:29:10 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:40 -0400
commit99c68135469e53eace92877f7279b4175ef80c8b (patch)
tree98f04259b4d58a293f723e7e85e776df86e09b9a
parent1475672e5fdb6ca534762f373f0183b225d303d6 (diff)
downloadguix-99c68135469e53eace92877f7279b4175ef80c8b.tar.gz
gnu: python-pygments: Update to 2.12.0.
* gnu/packages/python-xyz.scm (python-pygments): Update to 2.12.0.
(python2-pygments): Delete variable.
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 1 insertions, 15 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2255d0c082..5b210bc4d9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4438,21 +4438,7 @@ text styles of documentation.")
     (synopsis "Syntax highlighting")
     (description
      "Pygments is a syntax highlighting package written in Python.")
-    (license license:bsd-2)
-    (properties `((python2-variant . ,(delay python2-pygments))))))
-
-;; Pygments 2.6 and later does not support Python 2.
-(define-public python2-pygments
-  (let ((base (package-with-python2 (strip-python2-variant python-pygments))))
-    (package
-      (inherit base)
-      (version "2.5.2")
-      (source (origin
-                (method url-fetch)
-                (uri (pypi-uri "Pygments" version))
-                (sha256
-                 (base32
-                  "1zmhnswy0wxfn0xprs9aqsvx2c3kmzfn2wx14q8cv3vpkxdamj4q")))))))
+    (license license:bsd-2)))
 
 (define-public python-pygments-github-lexers
   (package