summary refs log tree commit diff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-29 16:50:40 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-05 13:39:45 +0200
commit9a110021b363c2cc7198b19d22934cbee92c651d (patch)
tree685fca20cd416bb5d8188102034de9c02ba98318
parent6facf26f0eea08533323b5cebd441d520840df01 (diff)
downloadguix-9a110021b363c2cc7198b19d22934cbee92c651d.tar.gz
gnu: Add java-httpcomponents-httpcore-osgi.
* gnu/packages/java.scm (java-httpcomponents-httpcore-osgi): New variable.
-rw-r--r--gnu/packages/java.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 2106dfd074..fb8472f407 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -6242,6 +6242,32 @@ NIO.")))
     (description "This package provides the HttpCore benchmarking tool.  It is
 an Apache AB clone based on HttpCore.")))
 
+(define-public java-httpcomponents-httpcore-osgi
+  (package (inherit java-httpcomponents-httpcore)
+    (name "java-httpcomponents-httpcore-osgi")
+    (arguments
+     `(#:jar-name "httpcomponents-httpcore-osgi.jar"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chdir
+           (lambda _ (chdir "httpcore-osgi"))))))
+    (inputs
+     (modify-inputs (package-inputs java-httpcomponents-httpcore)
+                    (prepend java-httpcomponents-httpcore
+                             java-httpcomponents-httpcore-nio
+                             java-hamcrest-core)))
+    (native-inputs (list java-ops4j-pax-exam-core
+                         java-ops4j-pax-exam-core-junit
+                         java-ops4j-pax-exam-core-spi
+                         java-junit))
+    (description "HttpCore is a set of low level HTTP transport components
+that can be used to build custom client and server side HTTP services with a
+minimal footprint.  HttpCore supports two I/O models: blocking I/O model based
+on the classic Java I/O and non-blocking, event driven I/O model based on Java
+NIO.
+
+This package provides... some tests.")))
+
 (define-public java-httpcomponents-httpclient
   (package
     (name "java-httpcomponents-httpclient")