summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-07-10 13:35:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-07-10 21:35:28 +0200
commit9a3f66ee7b573e44111d7b8052d74b31d323c0e6 (patch)
treef09ab326702982b26326b5c2c18682f6d72b31c1
parent39e1bc5b021d32a4cbdae978670271edb70847cb (diff)
downloadguix-9a3f66ee7b573e44111d7b8052d74b31d323c0e6.tar.gz
gnu: Add r-wk.
* gnu/packages/cran.scm (r-wk): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a02ef296c7..8933213e13 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15867,6 +15867,32 @@ tessellations, and summarizes information about the tiles of the
 tessellation.")
     (license license:gpl2+)))
 
+(define-public r-wk
+  (package
+    (name "r-wk")
+    (version "0.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "wk" version))
+       (sha256
+        (base32
+         "0l49pg1ds02h1qji1fi2m67mncvgd1n905i0jx07frdxy0d3b9ys"))))
+    (properties `((upstream-name . "wk")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-cpp11" ,r-cpp11)))
+    (home-page "https://paleolimbot.github.io/wk/")
+    (synopsis "Lightweight well-known geometry parsing")
+    (description
+     "This package provides a minimal R and C++ API for parsing well-known
+binary and well-known text representation of geometries to and from R-native
+formats.  Well-known binary is compact and fast to parse; well-known text is
+human-readable and is useful for writing tests.  These formats are only useful
+in R if the information they contain can be accessed in R, for which
+high-performance functions are provided here.")
+    (license license:expat)))
+
 (define-public r-sf
   (package
     (name "r-sf")