summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2022-08-11 19:41:38 +0200
committerAndreas Enge <andreas@enge.fr>2022-08-11 19:41:38 +0200
commit9a97097af1ca8eb041b55829facca83b516bb024 (patch)
tree7514d0347020799750714d1a73e7d4dd66a6d05a
parentc1a6c6e6d74861b3371fecc9e992b99993564b85 (diff)
downloadguix-9a97097af1ca8eb041b55829facca83b516bb024.tar.gz
gnu: gap: Enable compilation of more optional packages.
* gnu/packages/algebra.scm (gap)<snippet>: Add to the whitelist GAP packages
with free licenses clarified in the latest release, and which do not require
additional inputs.
-rw-r--r--gnu/packages/algebra.scm25
1 files changed, 21 insertions, 4 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index c6b04ada4f..b3f0823daf 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1242,24 +1242,41 @@ xtensor provides:
                    "SmallGrp-"   ; artistic2.0
                    "transgrp"    ; artistic2.0 for data,
                                  ; gpl2 or gpl3 for code
-                   ;; Recommended package.
-                   "io-"         ; gpl3+
-                   ;; Optional packages, searched for at start,
-                   ;; and their depedencies.
+                   ;; Optional packages.
                    "alnuth-"
+                   "AutoDoc-"
+                   "automata-"
                    "autpgrp-"
+                   "crime-"
                    "crisp-"      ; bsd-2
                    "ctbllib"     ; gpl3+
+                   "datastructures"
                    "FactInt-"
                    "fga"
+                   "format"
+                   "groupoids-"
+                   "guarana"
+                   "idrel-"
+                   "images-"     ; mpl2.0
+                   "IntPic-"
+                   "io-"         ; gpl3+
                    "irredsol-"   ; bsd-2
                    "laguna-"
+                   "liering-"
+                   "MapClass-"
+                   "nilmat-"
+                   "NumericalSgps-"
+                   "OpenMath-"
+                   "orb-"        ; gpl3+
                    "polenta-"
                    "polycyclic-"
                    "radiroot-"
+                   "repsn-"
                    "resclasses-"
+                   "simpcomp"
                    "sophus-"
                    "tomlib-"
+                   "unipot-"
                    "utils-"))))))))
     (build-system gnu-build-system)
     (inputs