summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:07:07 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:11:07 +0100
commit9c52f8b8678b4d17655b8ca29f2748203f498d6f (patch)
treea51bca0b6a126cc44efde575fbc73278c3559e7a
parentc56a00a90fada361e2b534f868c9b44a1da552d0 (diff)
downloadguix-9c52f8b8678b4d17655b8ca29f2748203f498d6f.tar.gz
gnu: Remove ocaml4.07-ppx-expect.
* gnu/packages/ocaml.scm (ocaml4.07-ppx-expect): Remove variable.
(ocaml-ppx-expect)[properties]: Remove variant.

Change-Id: Iad2ab78be171d8e0c7526c27fd0c7f77e62c6c68
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 0 insertions, 25 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 6688f6c52b..8f811a28fc 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7330,7 +7330,6 @@ useful errors on failure.")
            ocaml-migrate-parsetree
            ocaml-re))
     (properties `((upstream-name . "ppx_expect")
-                  (ocaml4.07-variant . ,(delay ocaml4.07-ppx-expect))
                   (ocaml5.0-variant . ,(delay ocaml5.0-ppx-expect))))
     (home-page "https://github.com/janestreet/ppx_expect")
     (synopsis "Cram like framework for OCaml")
@@ -7363,30 +7362,6 @@ to denote the expected output.")
             "05r7wlmrhb5biwyw6bjcpmr77srglijcbf7nm7h2hiil0d0i7bkz"))))
        (properties '())))))
 
-(define-public ocaml4.07-ppx-expect
-  (package-with-ocaml4.07
-   (package
-     (inherit ocaml-ppx-expect)
-     (version "0.12.0")
-     (source
-      (janestreet-origin "ppx_expect" version
-                         "1zpci8c49yn2ixchmwjx1kf9pwybv3dnn4l2dgnd6m36qnkralfk"))
-     (propagated-inputs
-      `(("ocaml-base" ,ocaml-base)
-        ("ocaml-ppx-assert" ,ocaml-ppx-assert)
-        ("ocaml-ppx-compare" ,ocaml-ppx-compare)
-        ("ocaml-ppx-custom-printf" ,ocaml-ppx-custom-printf)
-        ("ocaml-ppx-fields-conv" ,ocaml-ppx-fields-conv)
-        ("ocaml-ppx-here" ,ocaml-ppx-here)
-        ("ocaml-ppx-inline-test" ,ocaml-ppx-inline-test)
-        ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
-        ("ocaml-ppx-variants-conv" ,ocaml-ppx-variants-conv)
-        ("ocaml-stdio" ,ocaml-stdio)
-        ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
-        ("ocaml-ppxlib" ,ocaml-ppxlib)
-        ("ocaml-re" ,ocaml-re)))
-     (properties `((upstream-name . "ppx_expect"))))))
-
 (define-public ocaml-ppx-js-style
   (package
     (name "ocaml-ppx-js-style")