summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:09:56 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:28 +0200
commit9db52549892f5dcb37c0a30f2999d913640961dc (patch)
tree96218cb025f32febd76abc68363a42ff5f7fa209
parent3b6080ccb293e7ee6dcde61691e7dfadd3ba17b1 (diff)
downloadguix-9db52549892f5dcb37c0a30f2999d913640961dc.tar.gz
gnu: Add texlive-pst-2dplot.
* gnu/packages/tex.scm (texlive-pst-2dplot): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0350257af5..7240134512 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -32306,6 +32306,26 @@ and with colour support.  There are macros for colouring or shading the cells
 of tables.")
     (license license:lppl1.3+)))
 
+(define-public texlive-pst-2dplot
+  (package
+    (name "texlive-pst-2dplot")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/pst-2dplot/"
+                   "tex/latex/pst-2dplot/")
+             (base32
+              "1lq39hdlqf4af16lx7qrs6x2hj10rsashgd3yl8659346a2mq75a")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/pst-2dplot")
+    (synopsis "PSTricks package for drawing 2D curves")
+    (description
+     "Pst-2dplot is a PSTricks package that offers an intuitive tool for
+plotting 2-d curves.  It defines an environment with commands similar to
+MATLAB for plotting.")
+    (license license:lppl)))
+
 (define-public texlive-pst-text
   (package
     (name "texlive-pst-text")