summary refs log tree commit diff
diff options
context:
space:
mode:
authorMike Rosset <mike.rosset@gmail.com>2020-01-14 03:04:59 -0800
committerPierre Neidhardt <mail@ambrevar.xyz>2020-01-15 16:29:45 +0100
commit9deae9828111274327955bc1e39ec446c6512e8a (patch)
tree3b25408a9f28b67506852983369d71138c439a09
parent353e9f733c7d9dacc809c86529e75c431c6fc80f (diff)
downloadguix-9deae9828111274327955bc1e39ec446c6512e8a.tar.gz
gnu: python-pyqt: Substitute the full path of <qprinter.h>.
* gnu/packages/qt.scm (python-pyqt)[phases]: When building
  python-pyqtwebengine, qprinter.h can not be found.  This substitutes the full
  path of qprinter.h in the qprinter sip specification file.
-rw-r--r--gnu/packages/qt.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 514577678e..c634f45845 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1947,6 +1947,17 @@ module provides support functions to the automatically generated code.")
                   ,@%gnu-build-system-modules)
        #:phases
        (modify-phases %standard-phases
+         ;; When building python-pyqtwebengine, <qprinter.h> can not be
+         ;; included.  Here we substitute the full path to the header in the
+         ;; store.
+         (add-before 'configure 'substitute-source
+           (lambda* (#:key inputs  #:allow-other-keys)
+             (let* ((qtbase (assoc-ref inputs "qtbase"))
+                    (qtprinter.h (string-append "\"" qtbase "/include/qt5/QtPrintSupport/qprinter.h\"")))
+               (substitute* "sip/QtPrintSupport/qprinter.sip"
+                 (("<qprinter.h>")
+                  qtprinter.h))
+               #t)))
          (replace 'configure
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))