summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-28 03:48:18 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-28 13:59:02 +0100
commit9e4546a2be4d91cc8bb498340923ef01ae94971b (patch)
treed352744b9bc3c0066241c83a7166b6e7c3f7ae9a
parenta2803e206b4e61727e7b74c39f9a395d37545cfd (diff)
downloadguix-9e4546a2be4d91cc8bb498340923ef01ae94971b.tar.gz
gnu: python-oslo.config: Update to 5.2.0.
* gnu/packages/openstack.scm (python-oslo.config): Update to 5.2.0.
[source](uri): Use PYPI-URI.
[arguments]: Remove field.
[propagated-inputs]: Add PYTHON-DEBTCOLLECTOR, PYTHON-OSLO.I18N, PYTHON-PBR,
PYTHON-RFC3986 and PYTHON-PYYAML.
[native-inputs]: Remove PYTHON-PBR and PYTHON-I18N.  Add PYTHON-BANDIT,
PYTHON-COVERAGE, PYTHON-OPENSTACKDOCSTHEME, PYTHON-RENO, PYTHON-SPHINX-1.6,
PYTHON-TESTREPOSITORY and PYTHON-TESTTOOLS.
-rw-r--r--gnu/packages/openstack.scm38
1 files changed, 21 insertions, 17 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 0c4c6eb759..e49fe8e903 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -380,31 +380,35 @@ common features used in Tempest.")
 (define-public python-oslo.config
   (package
     (name "python-oslo.config")
-    (version "2.4.0")
+    (version "5.2.0")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append
-             "https://pypi.python.org/packages/source/o/oslo.config/oslo.config-"
-             version
-             ".tar.gz"))
+       (uri (pypi-uri "oslo.config" version))
        (sha256
          (base32
-          "13r778jfb0fhna37c2pd1f2xipnsbd7zli7qhn96acrzymrwj5k1"))))
+          "0ymf7jxbq29fifyvkwhfiys1qvljqfxdw8ajwzwaf3yiqidgpxqd"))))
     (build-system python-build-system)
-    (arguments
-     '(#:tests? #f)) ; FIXME: Requires packaging python-argparse.
     (propagated-inputs
-      `(("python-netaddr" ,python-netaddr)
-        ("python-six" ,python-six)
-        ("python-stevedore" ,python-stevedore)))
+     `(("python-debtcollector" ,python-debtcollector)
+       ("python-netaddr" ,python-netaddr)
+       ("python-oslo.i18n" ,python-oslo.i18n)
+       ("python-pbr" ,python-pbr)
+       ("python-rfc3986" ,python-rfc3986)
+       ("python-six" ,python-six)
+       ("python-stevedore" ,python-stevedore)
+       ("python-pyyaml" ,python-pyyaml)))
     (native-inputs
-      `(("python-pbr" ,python-pbr)
-        ;; Tests
-        ("python-oslo.i18n" ,python-oslo.i18n)
-        ("python-mock" ,python-mock)
-        ("python-oslotest" ,python-oslotest)
-        ("python-testscenarios" ,python-testscenarios)))
+     `(("python-bandit" ,python-bandit)
+       ("python-coverage" ,python-coverage)
+       ("python-mock" ,python-mock)
+       ("python-openstackdocstheme" ,python-openstackdocstheme)
+       ("python-oslotest" ,python-oslotest)
+       ("python-reno" ,python-reno)
+       ("python-sphinx" ,python-sphinx-1.6)
+       ("python-testrepository" ,python-testrepository)
+       ("python-testscenarios" ,python-testscenarios)
+       ("python-testtools" ,python-testtools)))
     (home-page "https://launchpad.net/oslo")
     (synopsis "Oslo Configuration API")
     (description