summary refs log tree commit diff
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2024-01-08 02:52:55 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:50 +0200
commit9ea97ee211525d654698efaa6c0bcc318e21514c (patch)
treeb5d914554f507d0fe4abe87286657672bc8f9695
parent92ab337b1682ca7ae5c1bc61e99d0759e69f67a6 (diff)
downloadguix-9ea97ee211525d654698efaa6c0bcc318e21514c.tar.gz
gnu: Add rust-matchit-0.7.
* gnu/packages/crates-io.scm (rust-matchit-0.7): New variable.

Change-Id: I0d20d0eb43938d4e4f460bf49f70064b591a71f3
Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2f4ed17fc5..38e011405c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39268,6 +39268,26 @@ in html5ever/xml5ever")
        (("rust-rustc-test" ,rust-rustc-test-0.3)
         ("rust-serde-json" ,rust-serde-json-1))))))
 
+(define-public rust-matchit-0.7
+  (package
+    (name "rust-matchit")
+    (version "0.7.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "matchit" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "156bgdmmlv4crib31qhgg49nsjk88dxkdqp80ha2pk2rk6n6ax0f"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t))   ; Cut the dependency tree.
+    (home-page "https://github.com/ibraheemdev/matchit")
+    (synopsis "High performance, zero-copy URL router")
+    (description
+     "This package provides a high performance, zero-copy URL router.")
+    (license (list license:expat license:bsd-3))))
+
 (define-public rust-match-cfg-0.1
   (package
     (name "rust-match-cfg")