summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-07 16:40:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-07 18:44:04 +0100
commit9f33d76c33545ea2f47981ba5ec5936cdf767f3f (patch)
tree7b07f06333520968fcf4ee6c4251dfcba3a14d05
parent58bc8857fbc596ca3224df93a55157ecb9ba905e (diff)
downloadguix-9f33d76c33545ea2f47981ba5ec5936cdf767f3f.tar.gz
gnu: Add r-qlcmatrix.
* gnu/packages/cran.scm (r-qlcmatrix): New variable.
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0b59c8f832..b1a23b9eb1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8794,3 +8794,30 @@ large datasets (> 100,000 samples) very efficiently.")
     (synopsis "Combinatorics utilities")
     (description "This package provides assorted routines for combinatorics.")
     (license license:gpl2)))
+
+(define-public r-qlcmatrix
+  (package
+    (name "r-qlcmatrix")
+    (version "0.9.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "qlcMatrix" version))
+       (sha256
+        (base32
+         "0iqkcvvy8rxlk0s83sjq57dd6fadb18p5z31lzy0gnzv1hsy1x8y"))))
+    (properties `((upstream-name . "qlcMatrix")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-docopt" ,r-docopt)
+       ("r-matrix" ,r-matrix)
+       ("r-slam" ,r-slam)
+       ("r-sparsesvd" ,r-sparsesvd)))
+    (home-page "https://cran.r-project.org/web/packages/qlcMatrix")
+    (synopsis "Sparse matrix functions for quantitative language comparison")
+    (description
+     "This package provides an extension of the functionality of the Matrix
+package for using sparse matrices.  Some of the functions are very general,
+while other are highly specific for the special data format used for
+@dfn{quantitative language comparison} (QLC).")
+    (license license:gpl3)))