summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-10-31 18:21:17 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-11-05 10:56:34 +0100
commit9f5bd38f94fbde4806296756d77f887ffcb29b58 (patch)
treeb9ace5f70bcdd4b525c5152dc124d51e7513d193
parent46dea1241c801af5aa65e0c7b4e84bb0aff11273 (diff)
downloadguix-9f5bd38f94fbde4806296756d77f887ffcb29b58.tar.gz
gnu: extra-cmake-modules: Install pri-files into lib/qt5/.
This in accordance with the documentation in
ECMGeneratePriFile.cmake: "Packagers … want to set
`ECM_MKSPECS_INSTALL_DIR` to something like
`share/qt5/mkspecs/modules`." Our Qt5 is putting pri-files into
`lib/qt5/mkspecs/modules`.

* gnu/packages/kde-frameworks.scm(extra-cmake-modules)[#:phase fix-lib-path]:
  New substitute for file 'modules/ECMGeneratePriFile.cmake'.
-rw-r--r--gnu/packages/kde-frameworks.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 6a46f28684..59022f3f03 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -104,7 +104,11 @@
                 "_define_relative(QTQUICKIMPORTSDIR LIBDIR \"qt5/imports\"")
                ;; Install qml-files into lib/qt5/qml
                (("_define_relative\\(QMLDIR LIBDIR \"qml\"")
-                "_define_relative(QMLDIR LIBDIR \"qt5/qml\""))))
+                "_define_relative(QMLDIR LIBDIR \"qt5/qml\""))
+             (substitute* "modules/ECMGeneratePriFile.cmake"
+               ;; Install pri-files into lib/qt5/mkspecs
+               (("set\\(ECM_MKSPECS_INSTALL_DIR mkspecs/modules")
+                "set(ECM_MKSPECS_INSTALL_DIR lib/qt5/mkspecs/modules"))))
          ;; install and check phase are swapped to prevent install from failing
          ;; after testsuire has run
          (add-after 'install 'check-post-install