summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:42:54 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:14 +0200
commita00b83b2f1c3d79a6f08b4bfce20f1d576b9c4e8 (patch)
tree3255d2b344392d2e4d6c493834eae4ac8db635ef
parent311676f83d04e2393a295e38d3a846497332370f (diff)
downloadguix-a00b83b2f1c3d79a6f08b4bfce20f1d576b9c4e8.tar.gz
gnu: Add texlive-pythonhighlight.
* gnu/packages/tex.scm (texlive-pythonhighlight): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3d252b0754..e2dea613f4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5687,6 +5687,26 @@ elements such as keywords, identifiers, and comments.")
 algorithms in a natural manner.")
     (license license:lppl)))
 
+(define-public texlive-pythonhighlight
+  (package
+    (name "texlive-pythonhighlight")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/pythonhighlight/"
+                   "tex/latex/pythonhighlight/")
+             (base32
+              "1grvq2sih8klkvzgyrc4fpalv7q670l9q00vs8293n698bhmn72g")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/pythonhighlight")
+    (synopsis
+     "Highlighting of Python code, based on the @code{listings} package")
+    (description
+     "This package allows highlighting of Python code, based on the
+@code{listings} package.")
+    (license license:bsd-3)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")