summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-11 00:16:30 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-11 00:16:30 +0200
commita01e7f09cb368c270c0cb90969f6c7a1308bb067 (patch)
tree4713211d2faed9e3a8122320bc95325a3149ee30
parent8fc86d1f6f220691191091fc21de935699ddd66b (diff)
downloadguix-a01e7f09cb368c270c0cb90969f6c7a1308bb067.tar.gz
gnu: open-adventure: Improve package style.
* gnu/packages/games.scm (open-adventure)[arguments]: Use G-expressions.
<#:make-flags>: Be nicer with cross-compilation.
<#:phases>: Remove trailing #T.
[native-inputs]: Remove labels.  Re-order alphabetically.
-rw-r--r--gnu/packages/games.scm60
1 files changed, 29 insertions, 31 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e5576fbb1e..05901df782 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6952,38 +6952,36 @@ at their peak of economic growth and military prowess.
         (base32 "1n0fzrdlbc6px88qr574ww2q85xk43bv09jpmsskzv1l2cncwm37"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:make-flags (list "CC=gcc")
-       #:parallel-tests? #f             ;some tests fail non-deterministically
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)            ;no configure script
-         (add-before 'build 'use-echo
-           (lambda _
-             (substitute* (list "tests/Makefile" "tests/tapview")
-               (("/bin/echo") (which "echo")))
-             #t))
-         (add-after 'build 'build-manpage
-           (lambda _
-             ;; This target is missing a dependency
-             (substitute* "Makefile"
-               ((".adoc.6:" line)
-                (string-append line " advent.adoc")))
-             (invoke "make" ".adoc.6")))
-         ;; There is no install target.
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (bin (string-append out "/bin"))
-                    (man (string-append out "/share/man/man6")))
-               (install-file "advent" bin)
-               (install-file "advent.6" man))
-             #t)))))
+     (list
+      #:make-flags #~(list (string-append "CC=" #$(cc-for-target)))
+      #:parallel-tests? #f              ;some tests fail non-deterministically
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure)           ;no configure script
+          (add-before 'build 'use-echo
+            (lambda _
+              (substitute* (list "tests/Makefile" "tests/tapview")
+                (("/bin/echo") (which "echo")))))
+          (add-after 'build 'build-manpage
+            (lambda _
+              ;; This target is missing a dependency
+              (substitute* "Makefile"
+                ((".adoc.6:" line)
+                 (string-append line " advent.adoc")))
+              (invoke "make" ".adoc.6")))
+          ;; There is no install target.
+          (replace 'install
+            (lambda _
+              (let ((bin (string-append #$output "/bin"))
+                    (man (string-append #$output "/share/man/man6")))
+                (install-file "advent" bin)
+                (install-file "advent.6" man)))))))
     (native-inputs
-     `(("asciidoc" ,asciidoc)
-       ("libedit" ,libedit)
-       ("pkg-config" ,pkg-config)
-       ("python" ,python-wrapper)
-       ("python-pyyaml" ,python-pyyaml)))
+     (list asciidoc
+           libedit
+           pkg-config
+           python-pyyaml
+           python-wrapper))
     (home-page "https://gitlab.com/esr/open-adventure")
     (synopsis "Colossal Cave Adventure")
     (description