summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:44:52 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:29 +0200
commita05c52019435707c80f8e72adcd50b34017cede0 (patch)
treeb132c9184b24b958e836ef159c6d4c8d82a60217
parentf7885d984ee526be877cdac89ff94630384cbd90 (diff)
downloadguix-a05c52019435707c80f8e72adcd50b34017cede0.tar.gz
gnu: Add texlive-newtxsf.
* gnu/packages/tex.scm (texlive-newtxsf): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e79cfb54ca..f4893614b4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -19544,6 +19544,30 @@ enhancements to that package, and splits it in two parts (@code{newpxtext} and
 scaling, improved metrics, and other options.")
     (license (list license:lppl license:silofl1.1))))
 
+(define-public texlive-newtxsf
+  (package
+    (name "texlive-newtxsf")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/newtxsf/"
+                   "fonts/map/dvips/newtxsf/"
+                   "fonts/tfm/public/newtxsf/"
+                   "fonts/type1/public/newtxsf/"
+                   "fonts/vf/public/newtxsf/"
+                   "tex/latex/newtxsf/")
+             (base32
+              "1nmbh566ifkglk4wdgp297q5nab52ykda4xfi9q5w3c5rzw53y0v")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/newtxsf")
+    (synopsis "Sans-math fonts for use with @code{newtx}")
+    (description
+     "The package provides a maths support that amounts to modifications of
+the STIX sans serif Roman and Greek letters with most symbols taken from
+@code{newtxmath}.")
+    (license license:silofl1.1)))
+
 (define-public texlive-nicematrix
   (package
     (name "texlive-nicematrix")