summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-10-15 02:00:00 +0200
commita112b43b2a8425915c764a2bc9e6cf0ea58cb512 (patch)
tree43d6aa62aaaa63f649df9c90ac202d8afa8d562b
parentbdb664f7b0df111b0ff5a0f61bfca7fdb5786672 (diff)
downloadguix-a112b43b2a8425915c764a2bc9e6cf0ea58cb512.tar.gz
gnu: ppp: Update to 2.5.0.
* gnu/packages/samba.scm (ppp): Update to 2.5.0.
[arguments]: Move CC from #:make-flags
to #:configure-flags where it belongs.  Remind ./configure where openssl lives.
Build verbosely.  Remove obsolete 'patch-Makefile phase, and delete autogen.sh.
[native-inputs]: Add autoconf, automake, and libtool.
-rw-r--r--gnu/packages/samba.scm34
1 files changed, 15 insertions, 19 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index c8b8d03521..89a79cee2d 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -467,34 +467,30 @@ key-value pair databases and a real LDAP database.")
 (define-public ppp
   (package
     (name "ppp")
-    (version "2.4.9")
+    (version "2.5.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/ppp-project/ppp")
-                    (commit version)))
+                    (commit (string-append "ppp-" version))))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1bhhksdclsnkw54a517ndrw55q5zljjbh9pcqz1z4a2z2flxpsgk"))))
+                "1pkvaxi5318lvsadspj603wdkxah01vgjhywri7rv249p249vfr7"))))
     (build-system gnu-build-system)
     (arguments
-      (list #:tests? #f                    ;; No "check" target
-            #:make-flags #~(list (string-append "CC=" #$(cc-for-target)))
-            #:phases
-            #~(modify-phases %standard-phases
-                (add-before 'configure 'patch-Makefile
-                  (lambda* (#:key inputs #:allow-other-keys)
-                    (let ((openssl (assoc-ref inputs "openssl"))
-                          (libpcap (assoc-ref inputs "libpcap")))
-                      (substitute* "pppd/Makefile.linux"
-                        (("/usr/include/openssl")
-                         (string-append openssl "/include"))
-                        (("-DPPP_FILTER")
-                         (string-append "-DPPP_FILTER -I" libpcap "/include")))
-                      (substitute* "pppd/pppcrypt.h"
-                        (("des\\.h") "openssl/des.h")))
-                    #t)))))
+     (list #:tests? #f                  ; no tests
+           #:configure-flags
+           #~(list (string-append "CC=" #$(cc-for-target))
+                   (string-append "--with-openssl="
+                                  (assoc-ref %build-inputs "openssl")))
+           #:make-flags #~(list "V=1")  ; better build logs
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'bootstrap 'no-/bin/sh
+                 (lambda _ (delete-file "autogen.sh"))))))
+    (native-inputs
+     (list autoconf automake libtool))
     (inputs
      (list libpcap openssl))
     (synopsis "Implementation of the Point-to-Point Protocol")