summary refs log tree commit diff
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2018-05-28 23:03:19 +0200
committerClément Lassieur <clement@lassieur.org>2018-05-28 23:45:50 +0200
commita234ae38ba21578403b6ed9df2edb4104a343826 (patch)
treef77fe3c1d585d0ffe436a3252c15f7e498656211
parent77cc8778a39426a786217896ec589c8c9341aa8f (diff)
downloadguix-a234ae38ba21578403b6ed9df2edb4104a343826.tar.gz
gnu: wireshark: Fix build against Qt 5.11.
* gnu/packages/networking.scm (wireshark)[arguments]: Add a 'patch-source'
phase that includes missing headers.
-rw-r--r--gnu/packages/networking.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index a95f5d10e0..a662842739 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -21,6 +21,7 @@
 ;;; Copyright © 2018 Adam Van Ymeren <adam@vany.ca>
 ;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
 ;;; Copyright © 2018 Tonton <tonton@riseup.net>
+;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -588,7 +589,21 @@ of the same name.")
                             (assoc-ref %build-inputs "portaudio"))
              (string-append "--with-sbc=" (assoc-ref %build-inputs "sbc"))
              (string-append "--with-snappy=" (assoc-ref %build-inputs "snappy"))
-             (string-append "--with-zlib=" (assoc-ref %build-inputs "zlib")))))
+             (string-append "--with-zlib=" (assoc-ref %build-inputs "zlib")))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-source
+           (lambda _
+             ;; Fix build against Qt 5.11.
+             (substitute* "ui/qt/packet_format_group_box.cpp"
+               (("#include <QStyle>") "#include <QStyle>
+#include <QStyleOption>"))
+             (substitute* "ui/qt/time_shift_dialog.cpp"
+               (("#include <ui/time_shift.h>") "#include <ui/time_shift.h>
+#include <QStyleOption>"))
+             (substitute* "ui/qt/wireless_frame.cpp"
+               (("#include <QProcess>") "#include <QProcess>
+#include <QAbstractItemView>")))))))
     (synopsis "Network traffic analyzer")
     (description "Wireshark is a network protocol analyzer, or @dfn{packet
 sniffer}, that lets you capture and interactively browse the contents of