summary refs log tree commit diff
diff options
context:
space:
mode:
authorDave Love <fx@gnu.org>2017-09-04 18:04:21 +0100
committerLudovic Courtès <ludo@gnu.org>2017-09-12 08:58:27 +0200
commita247fe7b0deebf85d42a2d5eb21cac0ecd32a965 (patch)
treefb5f6a0e34c3938467f9946730e722af49334eff
parentb5831eb7718c458ece555fb5a895ed57d49e73cb (diff)
downloadguix-a247fe7b0deebf85d42a2d5eb21cac0ecd32a965.tar.gz
gnu: openmpi: Remove Valgrind from closure.
* gnu/packages/mpi.scm (openmpi)[arguments]: Elide romio config info to
avoid reference to valgrind.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/mpi.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index f7380fecbf..a6deee3244 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -148,16 +148,21 @@ bind processes, and much more.")
                                            (assoc-ref %build-inputs "hwloc")))
        #:phases (modify-phases %standard-phases
                   (add-before 'build 'remove-absolute
-                    ;; Remove compiler absolute file names (OPAL_FC_ABSOLUTE
-                    ;; etc.) to reduce the closure size.  See
-                    ;; <https://lists.gnu.org/archive/html/guix-devel/2017-07/msg00388.html>
-                    ;; and
-                    ;; <https://www.mail-archive.com/users@lists.open-mpi.org//msg31397.html>.
                     (lambda _
+                      ;; Remove compiler absolute file names (OPAL_FC_ABSOLUTE
+                      ;; etc.) to reduce the closure size.  See
+                      ;; <https://lists.gnu.org/archive/html/guix-devel/2017-07/msg00388.html>
+                      ;; and
+                      ;; <https://www.mail-archive.com/users@lists.open-mpi.org//msg31397.html>.
                       (substitute* '("orte/tools/orte-info/param.c"
                                      "oshmem/tools/oshmem_info/param.c"
                                      "ompi/tools/ompi_info/param.c")
                         (("_ABSOLUTE") ""))
+                      ;; Avoid valgrind (which pulls in gdb etc.).
+                      (substitute*
+                          '("./ompi/mca/io/romio/src/io_romio_component.c")
+                        (("MCA_io_romio_COMPLETE_CONFIGURE_FLAGS")
+                         "\"[elided to reduce closure]\""))
                       #t))
                   (add-before 'build 'scrub-timestamps ;reproducibility
                     (lambda _