summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-12-06 22:54:44 +0100
committerAndreas Enge <andreas@enge.fr>2013-12-06 22:54:44 +0100
commita2e520afbf12ee8015f16657bc32304a00d096c3 (patch)
treed73d1b801100562934eca76b665154bffeb6433a
parent1385ba4fd10b3bd4db1bc201e963baaaea8d136d (diff)
downloadguix-a2e520afbf12ee8015f16657bc32304a00d096c3.tar.gz
gnu: Add perl-xml-regexp.
* gnu/packages/xml.scm (perl-xml-regexp): New variable.
-rw-r--r--gnu/packages/xml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index f5c2e12302..e8115b3037 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -185,6 +185,29 @@ underlying XML parsing module (either XML::Parser or one of the SAX2
 parser modules).")
     (home-page "http://search.cpan.org/~grantm/XML-Simple-2.20/lib/XML/Simple.pm")))
 
+(define-public perl-xml-regexp
+  (package
+    (name "perl-xml-regexp")
+    (version "0.04")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "mirror://cpan/authors/id/T/TJ/TJMATHER/XML-RegExp-"
+                   version ".tar.gz"))
+             (sha256
+              (base32
+               "0m7wj00a2kik7wj0azhs1zagwazqh3hlz4255n75q21nc04r06fz"))))
+    (build-system perl-build-system)
+    (inputs
+     `(("perl-xml-parser" ,perl-xml-parser)))
+    (license (package-license perl))
+    (synopsis "Perl regular expressions for XML tokens")
+    (description
+     "XML::RegExp contains regular expressions for the following XML tokens:
+BaseChar, Ideographic, Letter, Digit, Extender, CombiningChar, NameChar,
+EntityRef, CharRef, Reference, Name, NmToken, and AttValue.")
+    (home-page "http://search.cpan.org/~tjmather/XML-RegExp/lib/XML/RegExp.pm")))
+
 (define-public xmlto
   (package
     (name "xmlto")