summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-05-23 10:25:44 +0800
committer宋文武 <iyzsong@gmail.com>2015-05-23 10:25:44 +0800
commita30a0455e9717175b1ce09f58b7e6ae5798fd645 (patch)
tree25944451cbdbaa9735e63c95544a53a62b6e9671
parentac462e52a85d710a5196ac066473be5ce03c28c2 (diff)
downloadguix-a30a0455e9717175b1ce09f58b7e6ae5798fd645.tar.gz
gnu: harfbuzz: Enable GObject integration.
* gnu/packages/gtk.scm (harfbuzz): Add glib to propagated-inputs.
  [native-inputs]: Add gobject-introspection.
  [arguments]<#:configure-flags>: Add "--with-gobject".
-rw-r--r--gnu/packages/gtk.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 3f3f16a9a4..590048e06c 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -151,11 +151,15 @@ affine transformation (scale, rotation, shear, etc.)")
     `(("cairo" ,cairo)
       ("graphite2" ,graphite2)
       ("icu4c" ,icu4c)))
+   (propagated-inputs
+    `(("glib" ,glib))) ; required by harfbuzz-gobject.pc
    (native-inputs
-    `(("pkg-config" ,pkg-config)
+    `(("gobject-introspection" ,gobject-introspection)
+      ("pkg-config" ,pkg-config)
       ("python" ,python-2))) ; incompatible with Python 3 (print syntax)
    (arguments
-    `(#:configure-flags `("--with-graphite2=yes")))
+    `(#:configure-flags `("--with-graphite2"
+                          "--with-gobject")))
    (synopsis "OpenType text shaping engine")
    (description
     "HarfBuzz is an OpenType text shaping engine.")