summary refs log tree commit diff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-01-31 14:16:51 +0100
committerRutger Helling <rhelling@mykolab.com>2018-01-31 14:26:40 +0100
commita4f99103cacf5bdfc8c4880ca37008f9d0b38dea (patch)
tree32d39ecd3921d10907c7fb8c58249587896a9edb
parentee5402bfce1aa7ffbe9d27ed6b1fe54c2202a4bb (diff)
downloadguix-a4f99103cacf5bdfc8c4880ca37008f9d0b38dea.tar.gz
gnu: spirv-headers: Update to commit 061097878467b8e040fbf153a837d844ef9f9f96.
* gnu/packages/vulkan.scm (spirv-headers): Update to commit
061097878467b8e040fbf153a837d844ef9f9f96.
-rw-r--r--gnu/packages/vulkan.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 2599919720..e82bac68b0 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -31,8 +31,10 @@
   #:use-module (gnu packages xorg))
 
 (define-public spirv-headers
-  (let ((commit "98b01515724c428d0f0a5d01deffcce0f5f5e61c")
-        (revision "1"))
+  ;; Keep updated in accordance with
+  ;; https://github.com/google/shaderc/blob/known-good/known_good.json
+  (let ((commit "061097878467b8e040fbf153a837d844ef9f9f96")
+        (revision "2"))
     (package
       (name "spirv-headers")
       (version (string-append "0.0-" revision "." (string-take commit 9)))
@@ -44,7 +46,7 @@
                (commit commit)))
          (sha256
           (base32
-           "15bknwkv3xwmjs3lmkp282a1wrp0da1b4lp45i4yiav04zmqygj2"))
+           "0bf9h6xc5fkncxnadwmqvpsjh7sdgns6is8prv1gvlfzrkvpjj17"))
          (file-name (string-append name "-" version "-checkout"))))
       (build-system cmake-build-system)
       (arguments