summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-04-08 13:54:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-04-08 21:48:22 +0300
commita512aa918168193249b8a277eab65e015d2dd9e3 (patch)
tree455540cfdd6143e7f2e08ab555f730d804066bc6
parentfc83a8913a04e8fdbe792664690ad81f0cbe3028 (diff)
downloadguix-a512aa918168193249b8a277eab65e015d2dd9e3.tar.gz
gnu: openshot: Use wrap-qt-program.
* gnu/packages/video.scm (openshot)[arguments]: Add more modules.
Adjust custom 'wrap-program phase to use wrap-qt-program.
-rw-r--r--gnu/packages/video.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index cf11f0e01f..8bf13c192e 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3383,6 +3383,11 @@ API.  It includes bindings for Python, Ruby, and other languages.")
        ("qtsvg" ,qtsvg)))
     (arguments
      `(#:tests? #f                      ;no tests
+       #:modules ((guix build python-build-system)
+                  (guix build qt-utils)
+                  (guix build utils))
+       #:imported-modules (,@%python-build-system-modules
+                            (guix build qt-utils))
        #:phases (modify-phases %standard-phases
                   (delete 'build)       ;install phase does all the work
                   (add-before 'install 'set-tmp-home
@@ -3392,12 +3397,10 @@ API.  It includes bindings for Python, Ruby, and other languages.")
                       (setenv "HOME" "/tmp")
                       #t))
                   (add-after 'install 'wrap-program
-                    (lambda* (#:key inputs outputs #:allow-other-keys)
-                      (wrap-program (string-append (assoc-ref outputs "out")
-                                                   "/bin/openshot-qt")
-                        `("QT_PLUGIN_PATH" prefix
-                          ,(list (string-append (assoc-ref inputs "qtsvg")
-                                                "/lib/qt5/plugins/")))))))))
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (let ((out (assoc-ref outputs "out")))
+                        (wrap-qt-program out "openshot-qt"))
+                      #t)))))
     (home-page "https://openshot.org")
     (synopsis "Video editor")
     (description "OpenShot takes your videos, photos, and music files and