summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-06-09 12:26:59 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-06-15 17:03:17 +0200
commita5b1ef84b5a1b3ccba7a5a291503522ea7ca5ef3 (patch)
treefc7d6084e82ffac44832750eb8ad8d6e043a2bb6
parent35adcc3a86f6c40753caf4ca3d069645ec58487b (diff)
downloadguix-a5b1ef84b5a1b3ccba7a5a291503522ea7ca5ef3.tar.gz
gnu: Add texlive-latex-l3kernel.
* gnu/packages/tex.scm (texlive-latex-l3kernel): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 842310a7f3..44f76aad88 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1091,6 +1091,29 @@ of file names.")
     ;; the latest version is 1.3c.
     (license license:lppl1.3c+)))
 
+(define-public texlive-latex-l3kernel
+  (package
+    (name "texlive-latex-l3kernel")
+    (version (number->string %texlive-revision))
+    (source (origin
+              (method svn-fetch)
+              (uri (texlive-ref "latex" "l3kernel"))
+              (sha256
+               (base32
+                "0ndqw0flhl20f4ny5lssp8rqpnj5kglyg59whbdrxbh2zc7w7j0b"))))
+    (build-system texlive-build-system)
+    (arguments
+     '(#:tex-directory "latex/l3kernel"))
+    (home-page "http://www.ctan.org/pkg/l3kernel")
+    (synopsis "LaTeX3 programmers’ interface")
+    (description
+     "The l3kernel bundle provides an implementation of the LaTeX3
+programmers’ interface, as a set of packages that run under LaTeX 2e.  The
+interface provides the foundation on which the LaTeX3 kernel and other future
+code are built: it is an API for TeX programmers.  The packages are set up so
+that the LaTeX3 conventions can be used with regular LaTeX 2e packages.")
+    (license license:lppl1.3c+)))
+
 (define texlive-texmf
   (package
    (name "texlive-texmf")