summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-01-01 18:03:17 +0100
committerLudovic Courtès <ludo@gnu.org>2018-01-01 18:21:55 +0100
commita5e3d59bb3281fffd26dfd4bd8a23567e5940e80 (patch)
tree63148e0434bd65ef82e3c073a60ec5f4b13e180e
parentf0aba3844035abce7a05ef4e7c0b6f3ed9e9b5c8 (diff)
downloadguix-a5e3d59bb3281fffd26dfd4bd8a23567e5940e80.tar.gz
gnu: python-jupyter-console: Make it installable.
Fixes <https://bugs.gnu.org/29860>.
Reported by Johannes Laute <j.laute3@googlemail.com>.

* gnu/packages/python.scm (python-jupyter-console-minimal)[name]: New field.
-rw-r--r--gnu/packages/python.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ce3aa299bc..07302c729e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014, 2017 Eric Bavier <bavier@member.fsf.org>
@@ -6511,6 +6511,7 @@ Jupyter kernels such as IJulia and IRKernel.")
 (define python-jupyter-console-minimal
   (package
     (inherit python-jupyter-console)
+    (name "python-jupyter-console-minimal")
     (arguments
      (substitute-keyword-arguments
          (package-arguments python-jupyter-console)