summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:25:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:15 +0200
commita5f43d63bee006dae9d9dec660d6b35334be0e4b (patch)
tree971b7c83ba4689507507eb156c33a7605b0537b9
parent3c917984e5258b4316b819dc5503f5704370f59c (diff)
downloadguix-a5f43d63bee006dae9d9dec660d6b35334be0e4b.tar.gz
gnu: Add texlive-hfoldsty.
* gnu/packages/tex.scm (texlive-hfoldsty): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dd5765dccd..6ecdc9e2aa 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14371,6 +14371,31 @@ an environment that enables the user to draw such a game in a trivial way.")
 the Computer Modern Bright fonts.")
     (license license:lppl)))
 
+(define-public texlive-hfoldsty
+  (package
+    (name "texlive-hfoldsty")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/hfoldsty/"
+                   "fonts/tfm/public/hfoldsty/"
+                   "fonts/vf/public/hfoldsty/"
+                   "source/fonts/hfoldsty/"
+                   "tex/latex/hfoldsty/")
+             (base32
+              "0skzw845i1b3lq76m4an4mpkm2w82hlpirnx4pckz3138nr1rlpf")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/hfoldsty")
+    (synopsis "Old style numerals with EC fonts")
+    (description
+     "The @code{hfoldsty} package provides virtual fonts for using old-style
+figures with the European Computer Modern fonts.  It does a similar job as the
+@code{eco} package but includes a couple of improvements, i.e., better kerning
+with guillemets, and support for character protruding using the
+@code{pdfcprot} package.")
+    (license license:gpl3+)))
+
 (define-public texlive-historische-zeitschrift
   (package
     (name "texlive-historische-zeitschrift")