summary refs log tree commit diff
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2016-08-17 10:27:04 -0500
committerEfraim Flashner <efraim@flashner.co.il>2016-09-06 22:09:09 +0300
commita61696216c6aded59dfb5d9fd9ab2f20aac8e095 (patch)
tree125935b30d9fd2796fe028d0afc6ab64b49dff22
parenta287fafef283de47fcc39338b1d343e221220ac7 (diff)
downloadguix-a61696216c6aded59dfb5d9fd9ab2f20aac8e095.tar.gz
gnu: go: Update to 1.7.
* gnu/packages/golang.scm (go-1.6): Update to 1.7, with corresponding
  minor changes to prebuild phase, and rename variable to...
  (go-1.7): ...this new variable.
  (go): Inherit from new "go-1.7".

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/golang.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 09d962dd1d..afa3a361b7 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
 ;;; Copyright © 2016 Andy Wingo <wingo@igalia.com>
 ;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 Petter <petter@mykolab.ch>
 ;;;
 ;;; This file is an addendum GNU Guix.
 ;;;
@@ -185,11 +186,11 @@ garbage collection, various safety features and in the style of communicating
 sequential processes (CSP) concurrent programming features added.")
     (license license:bsd-3)))
 
-(define-public go-1.6
+(define-public go-1.7
   (package
     (inherit go-1.4)
     (name "go")
-    (version "1.6.3")
+    (version "1.7")
     (source
      (origin
        (method url-fetch)
@@ -197,7 +198,7 @@ sequential processes (CSP) concurrent programming features added.")
                            name version ".src.tar.gz"))
        (sha256
         (base32
-         "002v6irgfd63zp9iza8nski5by0lar033j3ddpqiikw6bznsw9k3"))))
+         "1h712yd5wk5mrj2dixc9z2xlgksfks00yvglrkrgr488p8b0qs3j"))))
     (arguments
      (substitute-keyword-arguments (package-arguments go-1.4)
        ((#:phases phases)
@@ -216,11 +217,14 @@ sequential processes (CSP) concurrent programming features added.")
                  ;; Removing net/ tests, which fail when attempting to access
                  ;; network resources not present in the build container.
                  (for-each delete-file
-                           '("net/listen_test.go" "net/parse_test.go"))
+                           '("net/listen_test.go"
+                             "net/parse_test.go"
+                             "net/cgo_unix_test.go"))
 
                  (substitute* "os/os_test.go"
                    (("/usr/bin") (getcwd))
-                   (("/bin/pwd") (which "pwd")))
+                   (("/bin/pwd") (which "pwd"))
+                   (("/bin/sh") (which "sh")))
 
                  ;; Add libgcc to runpath
                  (substitute* "cmd/link/internal/ld/lib.go"
@@ -275,7 +279,7 @@ sequential processes (CSP) concurrent programming features added.")
 
                  ;; fix shebang for testar script
                  ;; note the target script is generated at build time.
-                 (substitute* "../misc/cgo/testcarchive/test.bash"
+                 (substitute* "../misc/cgo/testcarchive/carchive_test.go"
                    (("#!/usr/bin/env") (string-append "#!" (which "env"))))
 
                  (substitute* "net/lookup_unix.go"
@@ -336,4 +340,4 @@ sequential processes (CSP) concurrent programming features added.")
      `(("go" ,go-1.4)
        ,@(package-native-inputs go-1.4)))))
 
-(define-public go go-1.6)
+(define-public go go-1.7)