summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 19:59:03 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 11:22:54 +0200
commita626f256ac0b4e65f2f1a8077e6f199fadcf4778 (patch)
treeda3dc28b216c6220a94890ff3fea5d7e44206ada
parentaedb7042439889e417e524bd7ff0fa5991558739 (diff)
downloadguix-a626f256ac0b4e65f2f1a8077e6f199fadcf4778.tar.gz
gnu: Add texlive-qyxf-book.
* gnu/packages/tex.scm (texlive-qyxf-book): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index baae6360e6..16601d42b5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -19727,6 +19727,27 @@ package.")
 Holy Quran.  It adds eight Urdu translations to the @code{quran} package.")
     (license license:lppl1.3c)))
 
+(define-public texlive-qyxf-book
+  (package
+    (name "texlive-qyxf-book")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/qyxf-book/"
+                   "tex/latex/qyxf-book/")
+             (base32
+              "0sgjdfpmwjqh40sbanj772bwimbf3az7wah65hxaz5198xd67m1y")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/qyxf-book")
+    (synopsis "Book Template for Qian Yuan Xue Fu")
+    (description
+     "@code{qyxf-book} is a LaTeX document class (template) developed by Qian
+Yuan Xue Fu (QYXF), a student club of Xi'an Jiaotong University (XJTU).  It
+creates a minimalistic document style, and several color schemes are offered.
+Currently the template is only designed for Chinese typesetting.")
+    (license license:expat)))
+
 (define-public texlive-r-und-s
   (package
     (name "texlive-r-und-s")