summary refs log tree commit diff
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2017-07-27 16:45:19 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-08-02 14:08:33 +0200
commita70b03d413b196dbce4747f9f039ebf28d1c568a (patch)
treea1d0f7bb6e8e98793b337053c131757d11551819
parent0abf52642043f5ed4b1a9ce51026f7e9bad2f428 (diff)
downloadguix-a70b03d413b196dbce4747f9f039ebf28d1c568a.tar.gz
gnu: Add python-grako
* gnu/packages/python.scm (python-grako): New variable.
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 21e32c343d..cf77abdba5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5168,6 +5168,34 @@ Python language binding specification.")
 (define-public python2-drmaa
   (package-with-python2 python-drmaa))
 
+(define-public python-grako
+  (package
+    (name "python-grako")
+    (version "3.99.9")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (pypi-uri "grako" version ".zip"))
+       (sha256
+        (base32
+         "0r63i68wcnv63rfjkasq1ah81frz61a6mzbcnaxhrkdpx84p7hzw"))))
+    (build-system python-build-system)
+    (arguments '(#:tests? #f)) ; Test file 'grako.ebnf' is missing from archive.
+    (native-inputs
+     `(("unzip" ,unzip)
+       ("python-pytest" ,python-pytest-3.0)
+       ("python-pytest-runner" ,python-pytest-runner)))
+    (home-page "https://bitbucket.org/neogeny/grako")
+    (synopsis "EBNF parser generator")
+    (description
+     "Grako takes a grammar in a variation of EBNF as input, and outputs a
+memoizing PEG/Packrat parser in Python.")
+    (license license:bsd-3)))
+
+(define-public python2-grako
+  (package-with-python2 python-grako))
+
 (define-public python-gridmap
   (package
     (name "python-gridmap")