summary refs log tree commit diff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-05-21 13:10:08 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-05-21 13:23:41 +0100
commita7f89f97b73a732b7333b21e95946ed4c794b121 (patch)
treee6925f47b212e970bb67a39bf0209458ef8debc3
parent40b793fd51fde559d44b2d9d5a984377946ef944 (diff)
downloadguix-a7f89f97b73a732b7333b21e95946ed4c794b121.tar.gz
gnu: ikiwiki: Add missing input.
* gnu/packages/web.scm (ikiwiki)[inputs]: Add perl-xml-feed.
[arguments]: Add 'pre-check' phase.
-rw-r--r--gnu/packages/web.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index baea844e4f..cf9bff8b3b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4876,6 +4876,13 @@ NetSurf project.")
              (invoke "find"  "doc" "underlays" "-type" "f" "-exec"
                      "touch" "{}" "+")
              #t))
+         (add-before 'check 'pre-check
+           ;; XDG_DATA_DIRS is needed by the podcast.t test.
+           (lambda* (#:key inputs #:allow-other-keys)
+             (setenv "XDG_DATA_DIRS"
+                     (string-append (assoc-ref inputs "shared-mime-info")
+                                    "/share"))
+             #t))
          (add-after 'install 'wrap-programs
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out  (assoc-ref outputs "out"))
@@ -4907,6 +4914,7 @@ NetSurf project.")
        ("perl-lwpx-paranoidagent" ,perl-lwpx-paranoidagent)
        ("perl-mail-sendmail" ,perl-mail-sendmail)
        ("perl-timedate" ,perl-timedate)
+       ("perl-xml-feed" ,perl-xml-feed)
        ("perl-xml-sax" ,perl-xml-sax)
        ("perl-xml-simple" ,perl-xml-simple)
        ("perl-xml-twig" ,perl-xml-twig)