summary refs log tree commit diff
diff options
context:
space:
mode:
authorCollin J. Doering <collin@rekahsoft.ca>2021-11-19 18:06:56 -0500
committerLudovic Courtès <ludo@gnu.org>2022-01-01 15:11:51 +0100
commita840dbba07a676f698646a8ff03ca4c0ef30f7f1 (patch)
tree90da62565dacc10a655e5da198cd7a279dcf832f
parentda4b02ad3f79848b47d707c08bbf94b0ff41e702 (diff)
downloadguix-a840dbba07a676f698646a8ff03ca4c0ef30f7f1.tar.gz
gnu: Add go-github-com-kingpin
* gnu/packages/golang.scm (go-github-com-kingpin): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index add69bf599..e355332b2d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9071,6 +9071,32 @@ GNU/Linux, this is a proxy for the @command{xdg-open} command.")
       (home-page "https://github.com/skratchdot/open-golang")
       (license license:expat))))
 
+(define-public go-github-com-kingpin
+  (package
+    (name "go-github-com-kingpin")
+    (version "2.2.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/alecthomas/kingpin")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0mndnv3hdngr3bxp7yxfd47cas4prv98sqw534mx7vp38gd88n5r"))))
+    (build-system go-build-system)
+    (native-inputs
+     (list go-github-com-alecthomas-template go-github-com-alecthomas-units
+           go-github-com-stretchr-testify))
+    (arguments
+     '(#:import-path "github.com/alecthomas/kingpin"
+       #:phases %standard-phases))
+    (synopsis "Go library provides utilities for building command line interfaces")
+    (description
+     "Go library provides utilities for building command line interfaces.")
+    (home-page "https://github.com/alecthomas/kingpin")
+    (license license:expat)))
+
 (define-public go-github-com-alecthomas-template
   (let ((commit "a0175ee3bccc567396460bf5acd36800cb10c49c")
         (revision "0"))